Chaged to generate empty devel package.
[platform/core/uifw/libgbm.git] / packaging / libgbm.spec
1 %define _unpackaged_files_terminate_build 0
2
3 %define MAJOR_VER       1
4 %define MINOR_VER       0
5
6 Summary:        Wayland GBM for TIZEN
7 Name:           libgbm
8 Version:        %{MAJOR_VER}.%{MINOR_VER}.1
9 Release:        1
10 Group:          System/Libraries
11 License:        MIT
12 Source:         %{name}-%{version}.tar.gz
13
14 BuildRequires: autoconf
15 BuildRequires: libtool
16 BuildRequires: systemd-devel
17 BuildRequires: pkgconfig(libtbm)
18 BuildRequires: pkgconfig(wayland-tbm-server)
19
20 %description
21 Wayland Generic Buffer Management for TIZEN
22
23 %package devel
24 Summary:    Development header files for use with GBM
25 Group:      System/Libraries
26 Requires:   %{name}
27
28 %description devel
29 Nothing provide
30
31 %prep
32 %setup -q -n %{name}
33
34 %build
35 %reconfigure --disable-static --enable-tbm --enable-tbm-queue \
36             CFLAGS="${CFLAGS} -Wall -Werror"
37 make libdir=%{_libdir} major_ver=%{MAJOR_VER} minor_ver=%{MINOR_VER}
38
39 %install
40 %makeinstall major_ver=%{MAJOR_VER} minor_ver=%{MINOR_VER}
41 rm -f %{buildroot}/%{_libdir}/*.la
42
43 ln -sf libgbm.so.%{MAJOR_VER}.%{MINOR_VER}.0    %{buildroot}%{_libdir}/libgbm.so.%{MAJOR_VER}
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49 %files
50 %manifest packaging/libgbm.manifest
51 %license COPYING
52 %defattr(-,root,root,-)
53 %{_libdir}/libgbm.so.%{MAJOR_VER}
54 %{_libdir}/libgbm.so.%{MAJOR_VER}.%{MINOR_VER}.0
55
56 %files devel
57 %defattr(-,root,root,-)