15c3ebf6ef2cf413ec3c131844adead02ba81ff8
[platform/upstream/libexif.git] / packaging / libexif.spec
1 Name:           libexif
2 Version:        0.6.21
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        An EXIF Tag Parsing Library for Digital Cameras
6 Url:            http://libexif.sourceforge.net
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 BuildRequires:  doxygen
11 BuildRequires:  pkg-config
12 BuildRequires:  gettext-tools
13
14 %define debug_package_requires %{name} = %{version}-%{release}
15
16 %description
17 This library is used to parse EXIF information from JPEGs created by
18 digital cameras.
19
20 %package devel
21 Summary:        An EXIF Tag Parsing Library for Digital Cameras (Development files)
22 Group:          Development/Libraries/C and C++
23 Requires:       %{name} = %{version}
24 Requires:       glibc-devel
25
26 %description devel
27 This library is used to parse EXIF information from JPEGs created by
28 digital cameras.
29
30 %prep
31 %setup -q
32
33 %build
34 %reconfigure --with-pic \
35         --disable-static \
36         --with-doc-dir=%{_docdir}/%{name}
37 make 
38 ### %{?_smp_mflags}
39
40 %check
41 make check
42
43 %install
44 %make_install
45 %find_lang %{name}-12
46
47 %post  -p /sbin/ldconfig
48
49 %postun  -p /sbin/ldconfig
50
51 %files -f %{name}-12.lang
52 %license COPYING
53 %defattr(-,root,root)
54 %{_libdir}/*.so.*
55
56 %files devel
57 %defattr(-,root,root)
58 %doc %{_docdir}/%{name}
59 %{_libdir}/*.so
60 %{_libdir}/pkgconfig/*.pc
61 %{_includedir}/*
62
63 %changelog