resetting manifest requested domain to floor
[platform/upstream/libevent.git] / packaging / libevent.spec
1 Name:           libevent
2 Version:        2.0.20
3 Release:        0
4 Summary:        Library Providing an Event Handling API
5 License:        BSD-3-Clause
6 Group:          Development/Libraries/C and C++
7 Url:            http://monkey.org/~provos/libevent/
8 Source0:        http://monkey.org/~provos/libevent-%{version}-stable.tar.gz
9 Source1:        baselibs.conf 
10 Source1001:     libevent.manifest
11 BuildRequires:  pkgconfig
12
13 %description
14 The libevent library provides a mechanism to execute a function when a
15 specific event on a file descriptor occurs or after a given time has
16 passed.
17
18
19 %package devel
20 Summary:        Development files for libevent2
21 Group:          Development/Libraries/C and C++
22 Requires:       %name = %{version}
23 Requires:       glibc-devel
24 Provides:       %{name}:/usr/include/event.h
25
26 %description devel
27 The libevent library provides a mechanism to execute a function when a
28 specific event on a file descriptor occurs or after a given time has
29 passed.
30
31 This package holds the development files for libevent2.
32
33 %prep
34 %setup -q  -n %{name}-%{version}-stable
35 cp %{SOURCE1001} .
36
37 %build
38 %configure --disable-static
39 %{__make} %{?_smp_mflags}
40
41 %install
42 %make_install
43
44 %post  -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48 %files 
49 %manifest %{name}.manifest
50 %defattr(-,root,root,-)
51 %{_libdir}/%{name}-2.0.so.5*
52 %{_libdir}/%{name}_core-2.0.so.5*
53 %{_libdir}/%{name}_extra-2.0.so.5*
54 %{_libdir}/%{name}_pthreads-2.0.so.5*
55
56 %files devel
57 %manifest %{name}.manifest
58 %defattr(-,root,root)
59 %{_bindir}/event_rpcgen.py
60 %{_includedir}/*.h
61 %{_includedir}/event2
62 %{_libdir}/%{name}.so
63 %{_libdir}/%{name}_core.so
64 %{_libdir}/%{name}_extra.so
65 %{_libdir}/%{name}_pthreads.so
66 %{_libdir}/pkgconfig/%{name}.pc
67 %{_libdir}/pkgconfig/%{name}_pthreads.pc
68
69 %changelog