c6bd55a0c7ba3bdc8d7d1e1f35bc87c297ef4f00
[platform/upstream/libevdev.git] / packaging / libevdev.spec
1 Name:           libevdev
2 Version:        1.8.0
3 Release:        0
4 License:        MIT
5 Summary:        wrapper library for evdev input devices
6 Url:            git://anongit.freedesktop.org/libevdev
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 Source1001:             %name.manifest
10
11 BuildRequires:  doxygen
12 BuildRequires:  make
13 BuildRequires:  python
14
15 %{!?TZ_SYS_RO_SHARE: %global TZ_SYS_RO_SHARE /usr/share}
16
17 %description
18 libevdev is a wrapper library for evdev devices. it moves the common
19 tasks when dealing with evdev devices into a library and provides a library
20 interface to the callers, thus avoiding erroneous ioctls, etc.
21
22
23 %package devel
24 Summary:    wrapper library for evdev input devices
25 Group:      Development/Libraries
26 Requires:   %{name} = %{version}-%{release}
27
28 %description devel
29 libevdev is a wrapper library for evdev devices. it moves the common
30 tasks when dealing with evdev devices into a library and provides a library
31 interface to the callers, thus avoiding erroneous ioctls, etc.
32
33 %prep
34 %setup -q
35 cp %{SOURCE1001} .
36 %autogen
37
38 %build
39 make %{?jobs:-j%jobs} V=1
40
41 %install
42 %make_install
43 #%fdupes %{buildroot}
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49
50 %files
51 %manifest %{name}.manifest
52 %defattr(-,root,root)
53 %license COPYING
54 %{_libdir}/*.so.*
55 %{_datadir}/*
56
57
58 %files devel
59 %manifest %{name}.manifest
60 %defattr(-,root,root,-)
61 %{_includedir}/*
62 %{_libdir}/*.so
63 %{_libdir}/pkgconfig/*