f9abebd1ff6fe99cc6f06f4863601ed4e3039bbc
[platform/core/uifw/libeom.git] / packaging / libeom.spec
1 %bcond_with utest
2
3 Name: libeom
4 Summary: External Output Manager Library
5 Version: 1.0.3
6 Release: 1
7 Group: Graphics/X Window System
8 License: MIT
9 Source0: %{name}-%{version}.tar.gz
10 Source1001:     %name.manifest
11
12 BuildRequires:  pkgconfig(wayland-client)
13 BuildRequires:  pkgconfig(ecore-wayland)
14 BuildRequires:  pkgconfig(xdg-shell-client)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(gio-unix-2.0)
18 BuildRequires:  pkgconfig(capi-base-common)
19 BuildRequires:  pkgconfig(elementary)
20
21 %if %{with utest}
22 BuildRequires:  gtest-devel
23 %endif
24
25 %description
26 This package provides the runtime library to manage eo(External Output)
27
28 %package devel
29 Summary: External Output Manager Library development package
30 Group: Development/Libraries
31 Requires: %{name} = %{version}-%{release}
32 Requires: pkgconfig(capi-base-common)
33
34 %description devel
35 External Output Manager Library development package
36
37 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
38
39 %prep
40 %setup -q
41 cp %{SOURCE1001} .
42
43 %build
44 export CFLAGS="-g -O0 -Wall -Werror -Wno-error=deprecated-declarations"
45 export LDFLAGS="$LDFLAGS -Wl,--hash-style=both -Wl,--as-needed"
46 UTEST="no"
47
48 %if %{with utest}
49 UTEST="yes"
50 %endif
51
52 %reconfigure --disable-dlog --disable-static --with-utest=${UTEST}
53
54 make %{?_smp_mflags}
55
56 %if %{with utest}
57 make -C ut check
58 %endif
59
60 %install
61 rm -rf %{buildroot}
62 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
63 cp -af COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
64 %make_install
65
66 %remove_docs
67
68 %files
69 %manifest %{name}.manifest
70 %defattr(-,root,root,-)
71 %{TZ_SYS_RO_SHARE}/license/%{name}
72 %{_libdir}/libeom.so.*
73 %if %{with utest}
74 %{_bindir}/ut
75 %endif
76
77 %files devel
78 %manifest %{name}.manifest
79 %dir %{_includedir}/eom/
80 %{_includedir}/eom/*.h
81 %{_libdir}/libeom.so
82 %{_libdir}/pkgconfig/eom.pc
83