bdecb49fcc59335673b848f8ae7b2ac5647a7da1
[platform/core/uifw/libeom.git] / packaging / libeom.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name: libeom
5 Summary: External Output Manager Library
6 Version: 1.0.1
7 Release: 1
8 Group: Graphics/X Window System
9 License: MIT
10 Source0: %{name}-%{version}.tar.gz
11 Source1001:     %name.manifest
12
13 %if %{with wayland}
14 BuildRequires:  pkgconfig(wayland-client)
15 BuildRequires:  pkgconfig(ecore-wayland)
16 %else
17 %endif
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(dbus-1)
20 BuildRequires:  pkgconfig(glib-2.0)
21 BuildRequires:  pkgconfig(gio-unix-2.0)
22 BuildRequires:  pkgconfig(capi-base-common)
23 BuildRequires:  pkgconfig(elementary)
24
25 %description
26 This package provides the runtime library to manage eo(External Output)
27
28 %package devel
29 Summary: External Output Manager Library development package
30 Group: Development/Libraries
31 Requires: %{name} = %{version}-%{release}
32 Requires: pkgconfig(capi-base-common)
33
34 %description devel
35 External Output Manager Library development package
36
37 %prep
38 %setup -q
39 cp %{SOURCE1001} .
40
41 %build
42 export CFLAGS="-g -O0 -Wall -Werror -Wno-error=deprecated-declarations"
43 export LDFLAGS="$LDFLAGS -Wl,--hash-style=both -Wl,--as-needed"
44 %if %{with wayland}
45 %reconfigure --disable-dlog --disable-static --with-eom-platform=WAYLAND
46 %else
47 %if 0%{?tizen_version_major} == 2
48 %reconfigure --disable-dlog --disable-static --with-eom-platform=X11 --with-tizen-version=TIZEN_2_X
49 %else
50 %reconfigure --disable-dlog --disable-static --with-eom-platform=X11 --with-tizen-version=TIZEN_3_X
51 %endif
52 %endif
53
54 make %{?_smp_mflags}
55
56 %install
57 rm -rf %{buildroot}
58 mkdir -p %{buildroot}/usr/share/license
59 cp -af COPYING %{buildroot}/usr/share/license/%{name}
60 %make_install
61
62 %remove_docs
63
64 %files
65 %manifest %{name}.manifest
66 %defattr(-,root,root,-)
67 /usr/share/license/%{name}
68 %{_libdir}/libeom.so.*
69
70 %files devel
71 %manifest %{name}.manifest
72 %dir %{_includedir}/eom/
73 %{_includedir}/eom/*.h
74 %{_libdir}/libeom.so
75 %{_libdir}/pkgconfig/eom.pc
76