provide eom server protocol through eom-server-protocol.so library
[platform/core/uifw/libeom.git] / packaging / libeom.spec
1 %bcond_with utest
2
3 Name: libeom
4 Summary: External Output Manager Library
5 Version: 1.0.3
6 Release: 1
7 Group: Graphics/X Window System
8 License: MIT
9 Source0: %{name}-%{version}.tar.gz
10 Source1001:     %name.manifest
11
12 BuildRequires:  pkgconfig(wayland-client)
13 BuildRequires:  pkgconfig(ecore-wayland)
14 BuildRequires:  pkgconfig(xdg-shell-client)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(gio-unix-2.0)
18 BuildRequires:  pkgconfig(capi-base-common)
19 BuildRequires:  pkgconfig(elementary)
20
21 %if %{with utest}
22 BuildRequires:  gtest-devel
23 %endif
24
25 %description
26 This package provides the runtime library to manage eo(External Output)
27
28 %package devel
29 Summary: External Output Manager Library development package
30 Group: Development/Libraries
31 Requires: %{name} = %{version}-%{release}
32 Requires: pkgconfig(capi-base-common)
33
34 %description devel
35 External Output Manager Library development package
36
37 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
38
39 %prep
40 %setup -q
41 cp %{SOURCE1001} .
42
43 %build
44 export CFLAGS="-g -O0 -Wall -Werror -Wno-error=deprecated-declarations"
45 export LDFLAGS="$LDFLAGS -Wl,--hash-style=both -Wl,--as-needed"
46 UTEST="no"
47
48 %if %{with utest}
49 UTEST="yes"
50 %endif
51
52 %reconfigure --disable-dlog --disable-static --with-utest=${UTEST}
53
54 make %{?_smp_mflags}
55
56 %if %{with utest}
57 make -C ut check
58 %endif
59
60 %install
61 rm -rf %{buildroot}
62 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
63 cp -af COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
64 mkdir -p %{buildroot}/usr/include
65 cp src/eom-server-protocol.h %{buildroot}/usr/include
66 %make_install
67
68 %remove_docs
69
70 %files
71 %manifest %{name}.manifest
72 %defattr(-,root,root,-)
73 %{TZ_SYS_RO_SHARE}/license/%{name}
74 %{_includedir}/eom-server-protocol.h
75 %{_libdir}/libeom.so.*
76 %{_libdir}/libeom-server-protocol.so.*
77 %if %{with utest}
78 %{_bindir}/ut
79 %endif
80
81 %files devel
82 %manifest %{name}.manifest
83 %dir %{_includedir}/eom/
84 %{_includedir}/eom/*.h
85 %{_libdir}/libeom.so
86 %{_libdir}/libeom-server-protocol.so
87 %{_libdir}/pkgconfig/eom.pc
88