add gtest files
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
1 Name:           libds-tizen
2 Version:        0.1.2
3 Release:        0
4 Summary:        Wayland Compositor Library for Tizen
5 License:        MIT
6 URL:            http://www.tizen.org/
7 Source:         %name-%version.tar.xz
8 Source1001:     %name.manifest
9
10 BuildRequires:  meson
11 BuildRequires:  pkgconfig(libds)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(wayland-client)
14 BuildRequires:  pkgconfig(wayland-protocols)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(tizen-extension-client)
17 BuildRequires:  pkgconfig(pixman-1)
18 BuildRequires:  pkgconfig(libdrm)
19 BuildRequires:  pkgconfig(xkbcommon)
20
21 BuildRequires:  pkgconfig(libtdm)
22 BuildRequires:  pkgconfig(libtbm)
23 BuildRequires:  pkgconfig(wayland-tbm-server)
24 BuildRequires:  pkgconfig(wayland-tbm-client)
25 BuildRequires:  pkgconfig(tizen-dpms-server)
26 BuildRequires:  pkgconfig(tizen-dpms-client)
27 BuildRequires:  pkgconfig(cynara-client)
28 BuildRequires:  pkgconfig(cynara-session)
29 BuildRequires:  pkgconfig(libsmack)
30 BuildRequires:  pkgconfig(gmock)
31
32 %description
33 Wayland Compositor Library for Tizen
34
35 ## libds-tizen-allocator-tbm
36 %package allocator-tbm
37 Summary: Allocator Library with TBM
38 Group:   Development/Libraries
39
40 %description allocator-tbm
41 Allocator Library with TBM
42
43 %package allocator-tbm-devel
44 Summary: TBM Allocator Development package
45 Group:   Development/Libraries
46
47 %description allocator-tbm-devel
48 TBM Allocator Development package
49
50 ## libds-tizen-backend-tdm
51 %package backend-tdm
52 Summary: Display Backend Library with TDM
53 Group:   Development/Libraries
54
55 %description backend-tdm
56 Display Backend Library with TDM
57
58 %package backend-tdm-devel
59 Summary: TDM Display Backend Development package
60 Group:   Development/Libraries
61
62 %description backend-tdm-devel
63 TDM Display Backend Development package
64
65 ## libds-tizen-tbm-server
66 %package tbm-server
67 Summary: Library for wayland-tbm-server
68 Group:   Development/Libraries
69
70 %description tbm-server
71 Library for tizen input devicemgr
72
73 %package tbm-server-devel
74 Summary: Development package for wayland-tbm-server
75 Group:   Development/Libraries
76
77 %description tbm-server-devel
78 Development package for tizen wayland-tbm-server
79
80 ## libds-tizen-keyrouter
81 %package keyrouter
82 Summary: Wayland Compositor Library for keyrouter
83 Group:   Development/Libraries
84
85 %description keyrouter
86 Wayland Compositor Library for tizen keyrouter
87
88 %package keyrouter-devel
89 Summary: Keyrouter Development package for Wayland Compositor Library
90 Group:   Development/Libraries
91
92 %description keyrouter-devel
93 Keyrouter Development package for Wayland Compositor Library
94
95 ## libds-tizen-input-devicemgr
96 %package input-devicemgr
97 Summary: Library for tizen input devicemgr
98 Group:   Development/Libraries
99
100 %description input-devicemgr
101 Library for tizen input devicemgr
102
103 %package input-devicemgr-devel
104 Summary: Development package for tizen input devicemgr
105 Group:   Development/Libraries
106
107 %description input-devicemgr-devel
108 Development package for tizen input devicemgr
109
110 ## libds-tizen-dpms
111 %package dpms
112 Summary: Library for tizen dpms
113 Group:   Development/Libraries
114
115 %description dpms
116 Library for tizen dpms
117
118 %package dpms-devel
119 Summary: Development package for tizen dpms
120 Group:   Development/Libraries
121
122 %description dpms-devel
123 Development package for tizen dpms
124
125 %prep
126 %setup -q
127 cp %{SOURCE1001} .
128
129 %build
130 meson setup \
131     --prefix /usr \
132     --libdir %{_libdir} \
133     --bindir %{_bindir} \
134     builddir \
135     -Dkeylayout_dir="%{TZ_SYS_RO_SHARE}/X11/xkb/tizen_key_layout.txt"
136 ninja -C builddir all
137
138 %install
139 export DESTDIR=%{buildroot}
140 ninja -C builddir install
141
142 %files allocator-tbm
143 %manifest %{name}.manifest
144 %defattr(-,root,root,-)
145 %license LICENSE
146 %{_libdir}/libds-tizen-allocator-tbm.so.*
147
148 %files allocator-tbm-devel
149 %manifest %{name}.manifest
150 %defattr(-,root,root,-)
151 %license LICENSE
152 %{_includedir}/libds-tizen/allocator/tbm.h
153 %{_libdir}/pkgconfig/libds-tizen-allocator-tbm.pc
154 %{_libdir}/libds-tizen-allocator-tbm.so
155
156 %files backend-tdm
157 %manifest %{name}.manifest
158 %defattr(-,root,root,-)
159 %license LICENSE
160 %{_libdir}/libds-tizen-backend-tdm.so.*
161
162 %files backend-tdm-devel
163 %manifest %{name}.manifest
164 %defattr(-,root,root,-)
165 %license LICENSE
166 %{_includedir}/libds-tizen/backend/tdm.h
167 %{_includedir}/libds-tizen/backend/tdm_output_hwc.h
168 %{_libdir}/pkgconfig/libds-tizen-backend-tdm.pc
169 %{_libdir}/libds-tizen-backend-tdm.so
170 %{_bindir}/tdm-backend
171 %{_bindir}/tinyds-tdm
172 %{_bindir}/tinyds-tdm-hwc
173 %{_bindir}/ds-simple-tbm
174
175 %files tbm-server
176 %manifest %{name}.manifest
177 %defattr(-,root,root,-)
178 %license LICENSE
179 %{_libdir}/libds-tizen-tbm-server.so.*
180
181 %files tbm-server-devel
182 %manifest %{name}.manifest
183 %defattr(-,root,root,-)
184 %license LICENSE
185 %{_includedir}/libds-tizen/tbm_server.h
186 %{_libdir}/pkgconfig/libds-tizen-tbm-server.pc
187 %{_libdir}/libds-tizen-tbm-server.so
188
189 %files keyrouter
190 %manifest %{name}.manifest
191 %defattr(-,root,root,-)
192 %license LICENSE
193 %{_libdir}/libds-tizen-keyrouter.so.*
194
195 %files keyrouter-devel
196 %manifest %{name}.manifest
197 %defattr(-,root,root,-)
198 %license LICENSE
199 %{_includedir}/libds-tizen/keyrouter.h
200 %{_libdir}/pkgconfig/libds-tizen-keyrouter.pc
201 %{_libdir}/libds-tizen-keyrouter.so
202
203 %files input-devicemgr
204 %manifest %{name}.manifest
205 %defattr(-,root,root,-)
206 %license LICENSE
207 %{_libdir}/libds-tizen-input-devicemgr.so.*
208
209 %files input-devicemgr-devel
210 %manifest %{name}.manifest
211 %defattr(-,root,root,-)
212 %license LICENSE
213 %{_includedir}/libds-tizen/input_devicemgr.h
214 %{_libdir}/pkgconfig/libds-tizen-input-devicemgr.pc
215 %{_libdir}/libds-tizen-input-devicemgr.so
216 %{_bindir}/tinyds-tdm-libinput
217 %{_bindir}/input-generator
218
219 %files dpms
220 %manifest %{name}.manifest
221 %defattr(-,root,root,-)
222 %license LICENSE
223 %{_libdir}/libds-tizen-dpms.so.*
224
225 %files dpms-devel
226 %manifest %{name}.manifest
227 %defattr(-,root,root,-)
228 %license LICENSE
229 %{_includedir}/libds-tizen/dpms.h
230 %{_libdir}/pkgconfig/libds-tizen-dpms.pc
231 %{_libdir}/libds-tizen-dpms.so
232 %{_bindir}/tinyds-tdm-dpms
233 %{_bindir}/ds-simple-dpms