Donot make libds-tizen package
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
1 Name:           libds-tizen
2 Version:        0.1.2
3 Release:        0
4 Summary:        Wayland Compositor Library for Tizen
5 License:        MIT
6 URL:            http://www.tizen.org/
7 Source:         %name-%version.tar.xz
8 Source1001:     %name.manifest
9
10 BuildRequires:  meson
11 BuildRequires:  pkgconfig(libds)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(wayland-client)
14 BuildRequires:  pkgconfig(wayland-protocols)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(tizen-extension-client)
17 BuildRequires:  pkgconfig(pixman-1)
18 BuildRequires:  pkgconfig(libdrm)
19 BuildRequires:  pkgconfig(xkbcommon)
20
21 BuildRequires:  pkgconfig(libtdm)
22 BuildRequires:  pkgconfig(libtbm)
23 BuildRequires:  pkgconfig(wayland-tbm-server)
24 BuildRequires:  pkgconfig(wayland-tbm-client)
25 BuildRequires:  pkgconfig(tizen-dpms-server)
26 BuildRequires:  pkgconfig(tizen-dpms-client)
27 BuildRequires:  pkgconfig(cynara-client)
28 BuildRequires:  pkgconfig(cynara-session)
29 BuildRequires:  pkgconfig(libsmack)
30
31 %description
32 Wayland Compositor Library for Tizen
33
34 ## libds-tizen-allocator-tbm
35 %package allocator-tbm
36 Summary: Allocator Library with TBM
37 Group:   Development/Libraries
38
39 %description allocator-tbm
40 Allocator Library with TBM
41
42 %package allocator-tbm-devel
43 Summary: TBM Allocator Development package
44 Group:   Development/Libraries
45
46 %description allocator-tbm-devel
47 TBM Allocator Development package
48
49 ## libds-tizen-backend-tdm
50 %package backend-tdm
51 Summary: Display Backend Library with TDM
52 Group:   Development/Libraries
53
54 %description backend-tdm
55 Display Backend Library with TDM
56
57 %package backend-tdm-devel
58 Summary: TDM Display Backend Development package
59 Group:   Development/Libraries
60
61 %description backend-tdm-devel
62 TDM Display Backend Development package
63
64 ## libds-tizen-tbm-server
65 %package tbm-server
66 Summary: Library for wayland-tbm-server
67 Group:   Development/Libraries
68
69 %description tbm-server
70 Library for tizen input devicemgr
71
72 %package tbm-server-devel
73 Summary: Development package for wayland-tbm-server
74 Group:   Development/Libraries
75
76 %description tbm-server-devel
77 Development package for tizen wayland-tbm-server
78
79 ## libds-tizen-keyrouter
80 %package keyrouter
81 Summary: Wayland Compositor Library for keyrouter
82 Group:   Development/Libraries
83
84 %description keyrouter
85 Wayland Compositor Library for tizen keyrouter
86
87 %package keyrouter-devel
88 Summary: Keyrouter Development package for Wayland Compositor Library
89 Group:   Development/Libraries
90
91 %description keyrouter-devel
92 Keyrouter Development package for Wayland Compositor Library
93
94 ## libds-tizen-input-devicemgr
95 %package input-devicemgr
96 Summary: Library for tizen input devicemgr
97 Group:   Development/Libraries
98
99 %description input-devicemgr
100 Library for tizen input devicemgr
101
102 %package input-devicemgr-devel
103 Summary: Development package for tizen input devicemgr
104 Group:   Development/Libraries
105
106 %description input-devicemgr-devel
107 Development package for tizen input devicemgr
108
109 ## libds-tizen-dpms
110 %package dpms
111 Summary: Library for tizen dpms
112 Group:   Development/Libraries
113
114 %description dpms
115 Library for tizen dpms
116
117 %package dpms-devel
118 Summary: Development package for tizen dpms
119 Group:   Development/Libraries
120
121 %description dpms-devel
122 Development package for tizen dpms
123
124 %prep
125 %setup -q
126 cp %{SOURCE1001} .
127
128 %build
129 meson setup \
130     --prefix /usr \
131     --libdir %{_libdir} \
132     --bindir %{_bindir} \
133     builddir \
134     -Dkeylayout_dir="%{TZ_SYS_RO_SHARE}/X11/xkb/tizen_key_layout.txt"
135 ninja -C builddir all
136
137 %install
138 export DESTDIR=%{buildroot}
139 ninja -C builddir install
140
141 %files allocator-tbm
142 %manifest %{name}.manifest
143 %defattr(-,root,root,-)
144 %license LICENSE
145 %{_libdir}/libds-tizen-allocator-tbm.so.*
146
147 %files allocator-tbm-devel
148 %manifest %{name}.manifest
149 %defattr(-,root,root,-)
150 %license LICENSE
151 %{_includedir}/libds-tizen/allocator/tbm.h
152 %{_libdir}/pkgconfig/libds-tizen-allocator-tbm.pc
153 %{_libdir}/libds-tizen-allocator-tbm.so
154
155 %files backend-tdm
156 %manifest %{name}.manifest
157 %defattr(-,root,root,-)
158 %license LICENSE
159 %{_libdir}/libds-tizen-backend-tdm.so.*
160
161 %files backend-tdm-devel
162 %manifest %{name}.manifest
163 %defattr(-,root,root,-)
164 %license LICENSE
165 %{_includedir}/libds-tizen/backend/tdm.h
166 %{_includedir}/libds-tizen/backend/tdm_output_hwc.h
167 %{_libdir}/pkgconfig/libds-tizen-backend-tdm.pc
168 %{_libdir}/libds-tizen-backend-tdm.so
169 %{_bindir}/tdm-backend
170 %{_bindir}/tinyds-tdm
171 %{_bindir}/tinyds-tdm-hwc
172 %{_bindir}/ds-simple-tbm
173
174 %files tbm-server
175 %manifest %{name}.manifest
176 %defattr(-,root,root,-)
177 %license LICENSE
178 %{_libdir}/libds-tizen-tbm-server.so.*
179
180 %files tbm-server-devel
181 %manifest %{name}.manifest
182 %defattr(-,root,root,-)
183 %license LICENSE
184 %{_includedir}/libds-tizen/tbm-server.h
185 %{_libdir}/pkgconfig/libds-tizen-tbm-server.pc
186 %{_libdir}/libds-tizen-tbm-server.so
187
188 %files keyrouter
189 %manifest %{name}.manifest
190 %defattr(-,root,root,-)
191 %license LICENSE
192 %{_libdir}/libds-tizen-keyrouter.so.*
193
194 %files keyrouter-devel
195 %manifest %{name}.manifest
196 %defattr(-,root,root,-)
197 %license LICENSE
198 %{_includedir}/libds-tizen/keyrouter.h
199 %{_libdir}/pkgconfig/libds-tizen-keyrouter.pc
200 %{_libdir}/libds-tizen-keyrouter.so
201
202 %files input-devicemgr
203 %manifest %{name}.manifest
204 %defattr(-,root,root,-)
205 %license LICENSE
206 %{_libdir}/libds-tizen-input-devicemgr.so.*
207
208 %files input-devicemgr-devel
209 %manifest %{name}.manifest
210 %defattr(-,root,root,-)
211 %license LICENSE
212 %{_includedir}/libds-tizen/input-devicemgr.h
213 %{_libdir}/pkgconfig/libds-tizen-input-devicemgr.pc
214 %{_libdir}/libds-tizen-input-devicemgr.so
215 %{_bindir}/tinyds-tdm-libinput
216 %{_bindir}/input-generator
217
218 %files dpms
219 %manifest %{name}.manifest
220 %defattr(-,root,root,-)
221 %license LICENSE
222 %{_libdir}/libds-tizen-dpms.so.*
223
224 %files dpms-devel
225 %manifest %{name}.manifest
226 %defattr(-,root,root,-)
227 %license LICENSE
228 %{_includedir}/libds-tizen/dpms.h
229 %{_libdir}/pkgconfig/libds-tizen-dpms.pc
230 %{_libdir}/libds-tizen-dpms.so
231 %{_bindir}/tinyds-tdm-dpms
232 %{_bindir}/ds-simple-dpms