add libds-tizen-allocator-tbm tests
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
1 Name:           libds-tizen
2 Version:        0.1.2
3 Release:        0
4 Summary:        Wayland Compositor Library for Tizen
5 License:        MIT
6 URL:            http://www.tizen.org/
7 Source:         %name-%version.tar.xz
8 Source1001:     %name.manifest
9
10 BuildRequires:  meson
11 BuildRequires:  pkgconfig(libds)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(wayland-client)
14 BuildRequires:  pkgconfig(wayland-protocols)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(tizen-extension-client)
17 BuildRequires:  pkgconfig(pixman-1)
18 BuildRequires:  pkgconfig(libdrm)
19 BuildRequires:  pkgconfig(xkbcommon)
20
21 BuildRequires:  pkgconfig(libtdm)
22 BuildRequires:  pkgconfig(libtbm)
23 BuildRequires:  pkgconfig(wayland-tbm-server)
24 BuildRequires:  pkgconfig(wayland-tbm-client)
25 BuildRequires:  pkgconfig(tizen-dpms-server)
26 BuildRequires:  pkgconfig(tizen-dpms-client)
27 BuildRequires:  pkgconfig(cynara-client)
28 BuildRequires:  pkgconfig(cynara-session)
29 BuildRequires:  pkgconfig(libsmack)
30 BuildRequires:  pkgconfig(gmock)
31
32 %description
33 Wayland Compositor Library for Tizen
34
35 ## libds-tizen-allocator-tbm
36 %package allocator-tbm
37 Summary: Allocator Library with TBM
38 Group:   Development/Libraries
39
40 %description allocator-tbm
41 Allocator Library with TBM
42
43 %package allocator-tbm-devel
44 Summary: TBM Allocator Development package
45 Group:   Development/Libraries
46
47 %description allocator-tbm-devel
48 TBM Allocator Development package
49
50 ## libds-tizen-backend-tdm
51 %package backend-tdm
52 Summary: Display Backend Library with TDM
53 Group:   Development/Libraries
54
55 %description backend-tdm
56 Display Backend Library with TDM
57
58 %package backend-tdm-devel
59 Summary: TDM Display Backend Development package
60 Group:   Development/Libraries
61
62 %description backend-tdm-devel
63 TDM Display Backend Development package
64
65 ## libds-tizen-tbm-server
66 %package tbm-server
67 Summary: Library for wayland-tbm-server
68 Group:   Development/Libraries
69
70 %description tbm-server
71 Library for tizen input devicemgr
72
73 %package tbm-server-devel
74 Summary: Development package for wayland-tbm-server
75 Group:   Development/Libraries
76
77 %description tbm-server-devel
78 Development package for tizen wayland-tbm-server
79
80 ## libds-tizen-keyrouter
81 %package keyrouter
82 Summary: Wayland Compositor Library for keyrouter
83 Group:   Development/Libraries
84
85 %description keyrouter
86 Wayland Compositor Library for tizen keyrouter
87
88 %package keyrouter-devel
89 Summary: Keyrouter Development package for Wayland Compositor Library
90 Group:   Development/Libraries
91
92 %description keyrouter-devel
93 Keyrouter Development package for Wayland Compositor Library
94
95 ## libds-tizen-input-devicemgr
96 %package input-devicemgr
97 Summary: Library for tizen input devicemgr
98 Group:   Development/Libraries
99
100 %description input-devicemgr
101 Library for tizen input devicemgr
102
103 %package input-devicemgr-devel
104 Summary: Development package for tizen input devicemgr
105 Group:   Development/Libraries
106
107 %description input-devicemgr-devel
108 Development package for tizen input devicemgr
109
110 ## libds-tizen-dpms
111 %package dpms
112 Summary: Library for tizen dpms
113 Group:   Development/Libraries
114
115 %description dpms
116 Library for tizen dpms
117
118 %package dpms-devel
119 Summary: Development package for tizen dpms
120 Group:   Development/Libraries
121
122 %description dpms-devel
123 Development package for tizen dpms
124
125 %prep
126 %setup -q
127 cp %{SOURCE1001} .
128
129 %build
130 meson setup \
131     --prefix /usr \
132     --libdir %{_libdir} \
133     --bindir %{_bindir} \
134     builddir \
135     -Dkeylayout_dir="%{TZ_SYS_RO_SHARE}/X11/xkb/tizen_key_layout.txt"
136 ninja -C builddir all
137
138 %install
139 export DESTDIR=%{buildroot}
140 ninja -C builddir install
141
142 %files allocator-tbm
143 %manifest %{name}.manifest
144 %defattr(-,root,root,-)
145 %license LICENSE
146 %{_libdir}/libds-tizen-allocator-tbm.so.*
147
148 %files allocator-tbm-devel
149 %manifest %{name}.manifest
150 %defattr(-,root,root,-)
151 %license LICENSE
152 %{_includedir}/libds-tizen/allocator/tbm.h
153 %{_libdir}/pkgconfig/libds-tizen-allocator-tbm.pc
154 %{_libdir}/libds-tizen-allocator-tbm.so
155 %{_bindir}/libds-tizen-allocator-tbm-tests
156
157 %files backend-tdm
158 %manifest %{name}.manifest
159 %defattr(-,root,root,-)
160 %license LICENSE
161 %{_libdir}/libds-tizen-backend-tdm.so.*
162
163 %files backend-tdm-devel
164 %manifest %{name}.manifest
165 %defattr(-,root,root,-)
166 %license LICENSE
167 %{_includedir}/libds-tizen/backend/tdm.h
168 %{_includedir}/libds-tizen/backend/tdm_output_hwc.h
169 %{_libdir}/pkgconfig/libds-tizen-backend-tdm.pc
170 %{_libdir}/libds-tizen-backend-tdm.so
171 %{_bindir}/tdm-backend
172 %{_bindir}/tinyds-tdm
173 %{_bindir}/tinyds-tdm-hwc
174 %{_bindir}/ds-simple-tbm
175
176 %files tbm-server
177 %manifest %{name}.manifest
178 %defattr(-,root,root,-)
179 %license LICENSE
180 %{_libdir}/libds-tizen-tbm-server.so.*
181
182 %files tbm-server-devel
183 %manifest %{name}.manifest
184 %defattr(-,root,root,-)
185 %license LICENSE
186 %{_includedir}/libds-tizen/tbm_server.h
187 %{_libdir}/pkgconfig/libds-tizen-tbm-server.pc
188 %{_libdir}/libds-tizen-tbm-server.so
189
190 %files keyrouter
191 %manifest %{name}.manifest
192 %defattr(-,root,root,-)
193 %license LICENSE
194 %{_libdir}/libds-tizen-keyrouter.so.*
195
196 %files keyrouter-devel
197 %manifest %{name}.manifest
198 %defattr(-,root,root,-)
199 %license LICENSE
200 %{_includedir}/libds-tizen/keyrouter.h
201 %{_libdir}/pkgconfig/libds-tizen-keyrouter.pc
202 %{_libdir}/libds-tizen-keyrouter.so
203
204 %files input-devicemgr
205 %manifest %{name}.manifest
206 %defattr(-,root,root,-)
207 %license LICENSE
208 %{_libdir}/libds-tizen-input-devicemgr.so.*
209
210 %files input-devicemgr-devel
211 %manifest %{name}.manifest
212 %defattr(-,root,root,-)
213 %license LICENSE
214 %{_includedir}/libds-tizen/input_devicemgr.h
215 %{_libdir}/pkgconfig/libds-tizen-input-devicemgr.pc
216 %{_libdir}/libds-tizen-input-devicemgr.so
217 %{_bindir}/tinyds-tdm-libinput
218 %{_bindir}/input-generator
219
220 %files dpms
221 %manifest %{name}.manifest
222 %defattr(-,root,root,-)
223 %license LICENSE
224 %{_libdir}/libds-tizen-dpms.so.*
225
226 %files dpms-devel
227 %manifest %{name}.manifest
228 %defattr(-,root,root,-)
229 %license LICENSE
230 %{_includedir}/libds-tizen/dpms.h
231 %{_libdir}/pkgconfig/libds-tizen-dpms.pc
232 %{_libdir}/libds-tizen-dpms.so
233 %{_bindir}/tinyds-tdm-dpms
234 %{_bindir}/ds-simple-dpms