add test cases for ds_tizen_clipboard
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
1 Name:           libds-tizen
2 Version:        0.1.2
3 Release:        0
4 Summary:        Wayland Compositor Library for Tizen
5 License:        MIT
6 URL:            http://www.tizen.org/
7 Source:         %name-%version.tar.xz
8 Source1001:     %name.manifest
9
10 BuildRequires:  meson
11 BuildRequires:  pkgconfig(libds)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(wayland-client)
14 BuildRequires:  pkgconfig(wayland-protocols)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(tizen-extension-client)
17 BuildRequires:  pkgconfig(pixman-1)
18 BuildRequires:  pkgconfig(libdrm)
19 BuildRequires:  pkgconfig(xkbcommon)
20
21 BuildRequires:  pkgconfig(libtdm)
22 BuildRequires:  pkgconfig(libtbm)
23 BuildRequires:  pkgconfig(wayland-tbm-server)
24 BuildRequires:  pkgconfig(wayland-tbm-client)
25 BuildRequires:  pkgconfig(tizen-dpms-server)
26 BuildRequires:  pkgconfig(tizen-dpms-client)
27 BuildRequires:  pkgconfig(cynara-client)
28 BuildRequires:  pkgconfig(cynara-session)
29 BuildRequires:  pkgconfig(libsmack)
30 BuildRequires:  pkgconfig(gmock)
31
32 %description
33 Wayland Compositor Library for Tizen
34
35 ## libds-tizen-allocator-tbm
36 %package allocator-tbm
37 Summary: Allocator Library with TBM
38 Group:   Development/Libraries
39
40 %description allocator-tbm
41 Allocator Library with TBM
42
43 %package allocator-tbm-devel
44 Summary: TBM Allocator Development package
45 Group:   Development/Libraries
46
47 %description allocator-tbm-devel
48 TBM Allocator Development package
49
50 ## libds-tizen-backend-tdm
51 %package backend-tdm
52 Summary: Display Backend Library with TDM
53 Group:   Development/Libraries
54
55 %description backend-tdm
56 Display Backend Library with TDM
57
58 %package backend-tdm-devel
59 Summary: TDM Display Backend Development package
60 Group:   Development/Libraries
61
62 %description backend-tdm-devel
63 TDM Display Backend Development package
64
65 ## libds-tizen-tbm-server
66 %package tbm-server
67 Summary: Library for wayland-tbm-server
68 Group:   Development/Libraries
69
70 %description tbm-server
71 Library for tizen input devicemgr
72
73 %package tbm-server-devel
74 Summary: Development package for wayland-tbm-server
75 Group:   Development/Libraries
76
77 %description tbm-server-devel
78 Development package for tizen wayland-tbm-server
79
80 ## libds-tizen-keyrouter
81 %package keyrouter
82 Summary: Wayland Compositor Library for keyrouter
83 Group:   Development/Libraries
84
85 %description keyrouter
86 Wayland Compositor Library for tizen keyrouter
87
88 %package keyrouter-devel
89 Summary: Keyrouter Development package for Wayland Compositor Library
90 Group:   Development/Libraries
91
92 %description keyrouter-devel
93 Keyrouter Development package for Wayland Compositor Library
94
95 ## libds-tizen-input-devicemgr
96 %package input-devicemgr
97 Summary: Library for tizen input devicemgr
98 Group:   Development/Libraries
99
100 %description input-devicemgr
101 Library for tizen input devicemgr
102
103 %package input-devicemgr-devel
104 Summary: Development package for tizen input devicemgr
105 Group:   Development/Libraries
106
107 %description input-devicemgr-devel
108 Development package for tizen input devicemgr
109
110 ## libds-tizen-dpms
111 %package dpms
112 Summary: Library for tizen dpms
113 Group:   Development/Libraries
114
115 %description dpms
116 Library for tizen dpms
117
118 %package dpms-devel
119 Summary: Development package for tizen dpms
120 Group:   Development/Libraries
121
122 %description dpms-devel
123 Development package for tizen dpms
124
125 ## libds-tizen-indicator
126 %package indicator
127 Summary: Library for tizen indicator
128 Group:   Development/Libraries
129
130 %description indicator
131 Library for tizen indicator
132
133 %package indicator-devel
134 Summary: Development package for tizen indicator
135 Group:   Development/Libraries
136
137 %description indicator-devel
138 Development package for tizen indicator
139
140 ## libds-tizen-clipboard
141 %package clipboard
142 Summary: Library for tizen clipboard
143 Group:   Development/Libraries
144
145 %description clipboard
146 Library for tizen clipboard
147
148 %package clipboard-devel
149 Summary: Development package for tizen clipboard
150 Group:   Development/Libraries
151
152 %description clipboard-devel
153 Development package for tizen clipboard
154
155 %prep
156 %setup -q
157 cp %{SOURCE1001} .
158
159 %build
160 meson setup \
161     --prefix /usr \
162     --libdir %{_libdir} \
163     --bindir %{_bindir} \
164     builddir \
165     -Dkeylayout_dir="%{TZ_SYS_RO_SHARE}/X11/xkb/tizen_key_layout.txt"
166 ninja -C builddir all
167
168 %install
169 export DESTDIR=%{buildroot}
170 ninja -C builddir install
171
172 %files allocator-tbm
173 %manifest %{name}.manifest
174 %defattr(-,root,root,-)
175 %license LICENSE
176 %{_libdir}/libds-tizen-allocator-tbm.so.*
177
178 %files allocator-tbm-devel
179 %manifest %{name}.manifest
180 %defattr(-,root,root,-)
181 %license LICENSE
182 %{_includedir}/libds-tizen/allocator/tbm.h
183 %{_libdir}/pkgconfig/libds-tizen-allocator-tbm.pc
184 %{_libdir}/libds-tizen-allocator-tbm.so
185 %{_bindir}/libds-tizen-allocator-tbm-tests
186
187 %files backend-tdm
188 %manifest %{name}.manifest
189 %defattr(-,root,root,-)
190 %license LICENSE
191 %{_libdir}/libds-tizen-backend-tdm.so.*
192
193 %files backend-tdm-devel
194 %manifest %{name}.manifest
195 %defattr(-,root,root,-)
196 %license LICENSE
197 %{_includedir}/libds-tizen/backend/tdm.h
198 %{_includedir}/libds-tizen/backend/tdm_output_hwc.h
199 %{_libdir}/pkgconfig/libds-tizen-backend-tdm.pc
200 %{_libdir}/libds-tizen-backend-tdm.so
201 %{_bindir}/tdm-backend
202 %{_bindir}/tinyds-tdm
203 %{_bindir}/tinyds-tdm-hwc
204 %{_bindir}/ds-simple-tbm
205
206 %files tbm-server
207 %manifest %{name}.manifest
208 %defattr(-,root,root,-)
209 %license LICENSE
210 %{_libdir}/libds-tizen-tbm-server.so.*
211
212 %files tbm-server-devel
213 %manifest %{name}.manifest
214 %defattr(-,root,root,-)
215 %license LICENSE
216 %{_includedir}/libds-tizen/tbm_server.h
217 %{_libdir}/pkgconfig/libds-tizen-tbm-server.pc
218 %{_libdir}/libds-tizen-tbm-server.so
219
220 %files keyrouter
221 %manifest %{name}.manifest
222 %defattr(-,root,root,-)
223 %license LICENSE
224 %{_libdir}/libds-tizen-keyrouter.so.*
225
226 %files keyrouter-devel
227 %manifest %{name}.manifest
228 %defattr(-,root,root,-)
229 %license LICENSE
230 %{_includedir}/libds-tizen/keyrouter.h
231 %{_libdir}/pkgconfig/libds-tizen-keyrouter.pc
232 %{_libdir}/libds-tizen-keyrouter.so
233
234 %files input-devicemgr
235 %manifest %{name}.manifest
236 %defattr(-,root,root,-)
237 %license LICENSE
238 %{_libdir}/libds-tizen-input-devicemgr.so.*
239
240 %files input-devicemgr-devel
241 %manifest %{name}.manifest
242 %defattr(-,root,root,-)
243 %license LICENSE
244 %{_includedir}/libds-tizen/input_devicemgr.h
245 %{_libdir}/pkgconfig/libds-tizen-input-devicemgr.pc
246 %{_libdir}/libds-tizen-input-devicemgr.so
247 %{_bindir}/tinyds-tdm-libinput
248 %{_bindir}/input-generator
249
250 %files dpms
251 %manifest %{name}.manifest
252 %defattr(-,root,root,-)
253 %license LICENSE
254 %{_libdir}/libds-tizen-dpms.so.*
255
256 %files dpms-devel
257 %manifest %{name}.manifest
258 %defattr(-,root,root,-)
259 %license LICENSE
260 %{_includedir}/libds-tizen/dpms.h
261 %{_libdir}/pkgconfig/libds-tizen-dpms.pc
262 %{_libdir}/libds-tizen-dpms.so
263 %{_bindir}/tinyds-tdm-dpms
264 %{_bindir}/ds-simple-dpms
265
266 %files indicator
267 %manifest %{name}.manifest
268 %defattr(-,root,root,-)
269 %license LICENSE
270 %{_libdir}/libds-tizen-indicator.so.*
271
272 %files indicator-devel
273 %manifest %{name}.manifest
274 %defattr(-,root,root,-)
275 %license LICENSE
276 %{_includedir}/libds-tizen/indicator.h
277 %{_libdir}/pkgconfig/libds-tizen-indicator.pc
278 %{_libdir}/libds-tizen-indicator.so
279 %{_bindir}/libds-tizen-indicator-tests
280
281 %files clipboard
282 %manifest %{name}.manifest
283 %defattr(-,root,root,-)
284 %license LICENSE
285 %{_libdir}/libds-tizen-clipboard.so.*
286
287 %files clipboard-devel
288 %manifest %{name}.manifest
289 %defattr(-,root,root,-)
290 %license LICENSE
291 %{_includedir}/libds-tizen/clipboard.h
292 %{_libdir}/pkgconfig/libds-tizen-clipboard.pc
293 %{_libdir}/libds-tizen-clipboard.so
294 %{_bindir}/libds-tizen-clipboard-tests