add test cases for ds_tizen_memory_flusher
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
1 Name:           libds-tizen
2 Version:        0.1.2
3 Release:        0
4 Summary:        Wayland Compositor Library for Tizen
5 License:        MIT
6 URL:            http://www.tizen.org/
7 Source:         %name-%version.tar.xz
8 Source1001:     %name.manifest
9
10 BuildRequires:  meson
11 BuildRequires:  pkgconfig(libds)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(wayland-client)
14 BuildRequires:  pkgconfig(wayland-protocols)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(tizen-extension-client)
17 BuildRequires:  pkgconfig(tizen-launch-server)
18 BuildRequires:  pkgconfig(tizen-launch-client)
19 BuildRequires:  pkgconfig(pixman-1)
20 BuildRequires:  pkgconfig(libdrm)
21 BuildRequires:  pkgconfig(xkbcommon)
22
23 BuildRequires:  pkgconfig(libtdm)
24 BuildRequires:  pkgconfig(libtbm)
25 BuildRequires:  pkgconfig(wayland-tbm-server)
26 BuildRequires:  pkgconfig(wayland-tbm-client)
27 BuildRequires:  pkgconfig(tizen-dpms-server)
28 BuildRequires:  pkgconfig(tizen-dpms-client)
29 BuildRequires:  pkgconfig(tizen-surface-server)
30 BuildRequires:  pkgconfig(tizen-surface-client)
31 BuildRequires:  pkgconfig(cynara-client)
32 BuildRequires:  pkgconfig(cynara-session)
33 BuildRequires:  pkgconfig(libsmack)
34 BuildRequires:  pkgconfig(gmock)
35
36 %description
37 Wayland Compositor Library for Tizen
38
39 ## libds-tizen-allocator-tbm
40 %package allocator-tbm
41 Summary: Allocator Library with TBM
42 Group:   Development/Libraries
43
44 %description allocator-tbm
45 Allocator Library with TBM
46
47 %package allocator-tbm-devel
48 Summary: TBM Allocator Development package
49 Group:   Development/Libraries
50
51 %description allocator-tbm-devel
52 TBM Allocator Development package
53
54 ## libds-tizen-backend-tdm
55 %package backend-tdm
56 Summary: Display Backend Library with TDM
57 Group:   Development/Libraries
58
59 %description backend-tdm
60 Display Backend Library with TDM
61
62 %package backend-tdm-devel
63 Summary: TDM Display Backend Development package
64 Group:   Development/Libraries
65
66 %description backend-tdm-devel
67 TDM Display Backend Development package
68
69 ## libds-tizen-tbm-server
70 %package tbm-server
71 Summary: Library for wayland-tbm-server
72 Group:   Development/Libraries
73
74 %description tbm-server
75 Library for tizen input devicemgr
76
77 %package tbm-server-devel
78 Summary: Development package for wayland-tbm-server
79 Group:   Development/Libraries
80
81 %description tbm-server-devel
82 Development package for tizen wayland-tbm-server
83
84 ## libds-tizen-keyrouter
85 %package keyrouter
86 Summary: Wayland Compositor Library for keyrouter
87 Group:   Development/Libraries
88
89 %description keyrouter
90 Wayland Compositor Library for tizen keyrouter
91
92 %package keyrouter-devel
93 Summary: Keyrouter Development package for Wayland Compositor Library
94 Group:   Development/Libraries
95
96 %description keyrouter-devel
97 Keyrouter Development package for Wayland Compositor Library
98
99 ## libds-tizen-input-devicemgr
100 %package input-devicemgr
101 Summary: Library for tizen input devicemgr
102 Group:   Development/Libraries
103
104 %description input-devicemgr
105 Library for tizen input devicemgr
106
107 %package input-devicemgr-devel
108 Summary: Development package for tizen input devicemgr
109 Group:   Development/Libraries
110
111 %description input-devicemgr-devel
112 Development package for tizen input devicemgr
113
114 ## libds-tizen-dpms
115 %package dpms
116 Summary: Library for tizen dpms
117 Group:   Development/Libraries
118
119 %description dpms
120 Library for tizen dpms
121
122 %package dpms-devel
123 Summary: Development package for tizen dpms
124 Group:   Development/Libraries
125
126 %description dpms-devel
127 Development package for tizen dpms
128
129 ## libds-tizen-indicator
130 %package indicator
131 Summary: Library for tizen indicator
132 Group:   Development/Libraries
133
134 %description indicator
135 Library for tizen indicator
136
137 %package indicator-devel
138 Summary: Development package for tizen indicator
139 Group:   Development/Libraries
140
141 %description indicator-devel
142 Development package for tizen indicator
143
144 ## libds-tizen-clipboard
145 %package clipboard
146 Summary: Library for tizen clipboard
147 Group:   Development/Libraries
148
149 %description clipboard
150 Library for tizen clipboard
151
152 %package clipboard-devel
153 Summary: Development package for tizen clipboard
154 Group:   Development/Libraries
155
156 %description clipboard-devel
157 Development package for tizen clipboard
158
159 ## libds-tizen-launch
160 %package launch
161 Summary: Library for tizen launch
162 Group:   Development/Libraries
163
164 %description launch
165 Library for tizen launch
166
167 %package launch-devel
168 Summary: Development package for tizen launch
169 Group:   Development/Libraries
170
171 %description launch-devel
172 Development package for tizen launch
173
174 ## libds-tizen-display-policy
175 %package display-policy
176 Summary: Library for tizen display-policy
177 Group:   Development/Libraries
178
179 %description display-policy
180 Library for tizen display-policy
181
182 %package display-policy-devel
183 Summary: Development package for tizen display-policy
184 Group:   Development/Libraries
185
186 %description display-policy-devel
187 Development package for tizen display-policy
188
189 ## libds-tizen-memory-flusher
190 %package memory-flusher
191 Summary: Library for tizen memory flusher
192 Group:   Development/Libraries
193
194 %description memory-flusher
195 Library for tizen memory flusher
196
197 %package memory-flusher-devel
198 Summary: Development package for tizen memory flusher
199 Group:   Development/Libraries
200
201 %description memory-flusher-devel
202 Development package for tizen memory flusher
203
204 %prep
205 %setup -q
206 cp %{SOURCE1001} .
207
208 %build
209 meson setup \
210     --prefix /usr \
211     --libdir %{_libdir} \
212     --bindir %{_bindir} \
213     builddir \
214     -Dkeylayout_dir="%{TZ_SYS_RO_SHARE}/X11/xkb/tizen_key_layout.txt"
215 ninja -C builddir all
216
217 %install
218 export DESTDIR=%{buildroot}
219 ninja -C builddir install
220
221 %files allocator-tbm
222 %manifest %{name}.manifest
223 %defattr(-,root,root,-)
224 %license LICENSE
225 %{_libdir}/libds-tizen-allocator-tbm.so.*
226
227 %files allocator-tbm-devel
228 %manifest %{name}.manifest
229 %defattr(-,root,root,-)
230 %license LICENSE
231 %{_includedir}/libds-tizen/allocator/tbm.h
232 %{_libdir}/pkgconfig/libds-tizen-allocator-tbm.pc
233 %{_libdir}/libds-tizen-allocator-tbm.so
234 %{_bindir}/libds-tizen-allocator-tbm-tests
235
236 %files backend-tdm
237 %manifest %{name}.manifest
238 %defattr(-,root,root,-)
239 %license LICENSE
240 %{_libdir}/libds-tizen-backend-tdm.so.*
241
242 %files backend-tdm-devel
243 %manifest %{name}.manifest
244 %defattr(-,root,root,-)
245 %license LICENSE
246 %{_includedir}/libds-tizen/backend/tdm.h
247 %{_includedir}/libds-tizen/backend/tdm_output_hwc.h
248 %{_libdir}/pkgconfig/libds-tizen-backend-tdm.pc
249 %{_libdir}/libds-tizen-backend-tdm.so
250 %{_bindir}/tdm-backend
251 %{_bindir}/tinyds-tdm
252 %{_bindir}/tinyds-tdm-hwc
253 %{_bindir}/ds-simple-tbm
254
255 %files tbm-server
256 %manifest %{name}.manifest
257 %defattr(-,root,root,-)
258 %license LICENSE
259 %{_libdir}/libds-tizen-tbm-server.so.*
260
261 %files tbm-server-devel
262 %manifest %{name}.manifest
263 %defattr(-,root,root,-)
264 %license LICENSE
265 %{_includedir}/libds-tizen/tbm_server.h
266 %{_libdir}/pkgconfig/libds-tizen-tbm-server.pc
267 %{_libdir}/libds-tizen-tbm-server.so
268
269 %files keyrouter
270 %manifest %{name}.manifest
271 %defattr(-,root,root,-)
272 %license LICENSE
273 %{_libdir}/libds-tizen-keyrouter.so.*
274
275 %files keyrouter-devel
276 %manifest %{name}.manifest
277 %defattr(-,root,root,-)
278 %license LICENSE
279 %{_includedir}/libds-tizen/keyrouter.h
280 %{_libdir}/pkgconfig/libds-tizen-keyrouter.pc
281 %{_libdir}/libds-tizen-keyrouter.so
282
283 %files input-devicemgr
284 %manifest %{name}.manifest
285 %defattr(-,root,root,-)
286 %license LICENSE
287 %{_libdir}/libds-tizen-input-devicemgr.so.*
288
289 %files input-devicemgr-devel
290 %manifest %{name}.manifest
291 %defattr(-,root,root,-)
292 %license LICENSE
293 %{_includedir}/libds-tizen/input_devicemgr.h
294 %{_libdir}/pkgconfig/libds-tizen-input-devicemgr.pc
295 %{_libdir}/libds-tizen-input-devicemgr.so
296 %{_bindir}/tinyds-tdm-libinput
297 %{_bindir}/input-generator
298
299 %files dpms
300 %manifest %{name}.manifest
301 %defattr(-,root,root,-)
302 %license LICENSE
303 %{_libdir}/libds-tizen-dpms.so.*
304
305 %files dpms-devel
306 %manifest %{name}.manifest
307 %defattr(-,root,root,-)
308 %license LICENSE
309 %{_includedir}/libds-tizen/dpms.h
310 %{_libdir}/pkgconfig/libds-tizen-dpms.pc
311 %{_libdir}/libds-tizen-dpms.so
312 %{_bindir}/tinyds-tdm-dpms
313 %{_bindir}/ds-simple-dpms
314
315 %files indicator
316 %manifest %{name}.manifest
317 %defattr(-,root,root,-)
318 %license LICENSE
319 %{_libdir}/libds-tizen-indicator.so.*
320
321 %files indicator-devel
322 %manifest %{name}.manifest
323 %defattr(-,root,root,-)
324 %license LICENSE
325 %{_includedir}/libds-tizen/indicator.h
326 %{_libdir}/pkgconfig/libds-tizen-indicator.pc
327 %{_libdir}/libds-tizen-indicator.so
328 %{_bindir}/libds-tizen-indicator-tests
329
330 %files clipboard
331 %manifest %{name}.manifest
332 %defattr(-,root,root,-)
333 %license LICENSE
334 %{_libdir}/libds-tizen-clipboard.so.*
335
336 %files clipboard-devel
337 %manifest %{name}.manifest
338 %defattr(-,root,root,-)
339 %license LICENSE
340 %{_includedir}/libds-tizen/clipboard.h
341 %{_libdir}/pkgconfig/libds-tizen-clipboard.pc
342 %{_libdir}/libds-tizen-clipboard.so
343 %{_bindir}/libds-tizen-clipboard-tests
344
345 <<<<<<< HEAD
346 %files launch
347 %manifest %{name}.manifest
348 %defattr(-,root,root,-)
349 %license LICENSE
350 %{_libdir}/libds-tizen-launch.so.*
351
352 %files launch-devel
353 %manifest %{name}.manifest
354 %defattr(-,root,root,-)
355 %license LICENSE
356 %{_includedir}/libds-tizen/launch/appinfo.h
357 %{_libdir}/pkgconfig/libds-tizen-launch.pc
358 %{_libdir}/libds-tizen-launch.so
359 %{_bindir}/libds-tizen-launch-appinfo-tests
360
361 %files display-policy
362 %manifest %{name}.manifest
363 %defattr(-,root,root,-)
364 %license LICENSE
365 %{_libdir}/libds-tizen-display-policy.so.*
366
367 %files display-policy-devel
368 %manifest %{name}.manifest
369 %defattr(-,root,root,-)
370 %license LICENSE
371 %{_includedir}/libds-tizen/display_policy.h
372 %{_libdir}/pkgconfig/libds-tizen-display-policy.pc
373 %{_libdir}/libds-tizen-display-policy.so
374 %{_bindir}/libds-tizen-display-policy-tests
375
376 %files memory-flusher
377 %manifest %{name}.manifest
378 %defattr(-,root,root,-)
379 %license LICENSE
380 %{_libdir}/libds-tizen-memory-flusher.so.*
381
382 %files memory-flusher-devel
383 %manifest %{name}.manifest
384 %defattr(-,root,root,-)
385 %license LICENSE
386 %{_includedir}/libds-tizen/memory_flusher.h
387 %{_libdir}/pkgconfig/libds-tizen-memory-flusher.pc
388 %{_libdir}/libds-tizen-memory-flusher.so
389 %{_bindir}/libds-tizen-memory-flusher-tests