add test cases for ds_tizen_display_policy
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
1 Name:           libds-tizen
2 Version:        0.1.2
3 Release:        0
4 Summary:        Wayland Compositor Library for Tizen
5 License:        MIT
6 URL:            http://www.tizen.org/
7 Source:         %name-%version.tar.xz
8 Source1001:     %name.manifest
9
10 BuildRequires:  meson
11 BuildRequires:  pkgconfig(libds)
12 BuildRequires:  pkgconfig(wayland-server)
13 BuildRequires:  pkgconfig(wayland-client)
14 BuildRequires:  pkgconfig(wayland-protocols)
15 BuildRequires:  pkgconfig(tizen-extension-server)
16 BuildRequires:  pkgconfig(tizen-extension-client)
17 BuildRequires:  pkgconfig(tizen-launch-server)
18 BuildRequires:  pkgconfig(tizen-launch-client)
19 BuildRequires:  pkgconfig(pixman-1)
20 BuildRequires:  pkgconfig(libdrm)
21 BuildRequires:  pkgconfig(xkbcommon)
22
23 BuildRequires:  pkgconfig(libtdm)
24 BuildRequires:  pkgconfig(libtbm)
25 BuildRequires:  pkgconfig(wayland-tbm-server)
26 BuildRequires:  pkgconfig(wayland-tbm-client)
27 BuildRequires:  pkgconfig(tizen-dpms-server)
28 BuildRequires:  pkgconfig(tizen-dpms-client)
29 BuildRequires:  pkgconfig(cynara-client)
30 BuildRequires:  pkgconfig(cynara-session)
31 BuildRequires:  pkgconfig(libsmack)
32 BuildRequires:  pkgconfig(gmock)
33
34 %description
35 Wayland Compositor Library for Tizen
36
37 ## libds-tizen-allocator-tbm
38 %package allocator-tbm
39 Summary: Allocator Library with TBM
40 Group:   Development/Libraries
41
42 %description allocator-tbm
43 Allocator Library with TBM
44
45 %package allocator-tbm-devel
46 Summary: TBM Allocator Development package
47 Group:   Development/Libraries
48
49 %description allocator-tbm-devel
50 TBM Allocator Development package
51
52 ## libds-tizen-backend-tdm
53 %package backend-tdm
54 Summary: Display Backend Library with TDM
55 Group:   Development/Libraries
56
57 %description backend-tdm
58 Display Backend Library with TDM
59
60 %package backend-tdm-devel
61 Summary: TDM Display Backend Development package
62 Group:   Development/Libraries
63
64 %description backend-tdm-devel
65 TDM Display Backend Development package
66
67 ## libds-tizen-tbm-server
68 %package tbm-server
69 Summary: Library for wayland-tbm-server
70 Group:   Development/Libraries
71
72 %description tbm-server
73 Library for tizen input devicemgr
74
75 %package tbm-server-devel
76 Summary: Development package for wayland-tbm-server
77 Group:   Development/Libraries
78
79 %description tbm-server-devel
80 Development package for tizen wayland-tbm-server
81
82 ## libds-tizen-keyrouter
83 %package keyrouter
84 Summary: Wayland Compositor Library for keyrouter
85 Group:   Development/Libraries
86
87 %description keyrouter
88 Wayland Compositor Library for tizen keyrouter
89
90 %package keyrouter-devel
91 Summary: Keyrouter Development package for Wayland Compositor Library
92 Group:   Development/Libraries
93
94 %description keyrouter-devel
95 Keyrouter Development package for Wayland Compositor Library
96
97 ## libds-tizen-input-devicemgr
98 %package input-devicemgr
99 Summary: Library for tizen input devicemgr
100 Group:   Development/Libraries
101
102 %description input-devicemgr
103 Library for tizen input devicemgr
104
105 %package input-devicemgr-devel
106 Summary: Development package for tizen input devicemgr
107 Group:   Development/Libraries
108
109 %description input-devicemgr-devel
110 Development package for tizen input devicemgr
111
112 ## libds-tizen-dpms
113 %package dpms
114 Summary: Library for tizen dpms
115 Group:   Development/Libraries
116
117 %description dpms
118 Library for tizen dpms
119
120 %package dpms-devel
121 Summary: Development package for tizen dpms
122 Group:   Development/Libraries
123
124 %description dpms-devel
125 Development package for tizen dpms
126
127 ## libds-tizen-indicator
128 %package indicator
129 Summary: Library for tizen indicator
130 Group:   Development/Libraries
131
132 %description indicator
133 Library for tizen indicator
134
135 %package indicator-devel
136 Summary: Development package for tizen indicator
137 Group:   Development/Libraries
138
139 %description indicator-devel
140 Development package for tizen indicator
141
142 ## libds-tizen-clipboard
143 %package clipboard
144 Summary: Library for tizen clipboard
145 Group:   Development/Libraries
146
147 %description clipboard
148 Library for tizen clipboard
149
150 %package clipboard-devel
151 Summary: Development package for tizen clipboard
152 Group:   Development/Libraries
153
154 %description clipboard-devel
155 Development package for tizen clipboard
156
157 ## libds-tizen-launch
158 %package launch
159 Summary: Library for tizen launch
160 Group:   Development/Libraries
161
162 %description launch
163 Library for tizen launch
164
165 %package launch-devel
166 Summary: Development package for tizen launch
167 Group:   Development/Libraries
168
169 %description launch-devel
170 Development package for tizen launch
171
172 ## libds-tizen-display-policy
173 %package display-policy
174 Summary: Library for tizen display-policy
175 Group:   Development/Libraries
176
177 %description display-policy
178 Library for tizen display-policy
179
180 %package display-policy-devel
181 Summary: Development package for tizen display-policy
182 Group:   Development/Libraries
183
184 %description display-policy-devel
185 Development package for tizen display-policy
186
187 %prep
188 %setup -q
189 cp %{SOURCE1001} .
190
191 %build
192 meson setup \
193     --prefix /usr \
194     --libdir %{_libdir} \
195     --bindir %{_bindir} \
196     builddir \
197     -Dkeylayout_dir="%{TZ_SYS_RO_SHARE}/X11/xkb/tizen_key_layout.txt"
198 ninja -C builddir all
199
200 %install
201 export DESTDIR=%{buildroot}
202 ninja -C builddir install
203
204 %files allocator-tbm
205 %manifest %{name}.manifest
206 %defattr(-,root,root,-)
207 %license LICENSE
208 %{_libdir}/libds-tizen-allocator-tbm.so.*
209
210 %files allocator-tbm-devel
211 %manifest %{name}.manifest
212 %defattr(-,root,root,-)
213 %license LICENSE
214 %{_includedir}/libds-tizen/allocator/tbm.h
215 %{_libdir}/pkgconfig/libds-tizen-allocator-tbm.pc
216 %{_libdir}/libds-tizen-allocator-tbm.so
217 %{_bindir}/libds-tizen-allocator-tbm-tests
218
219 %files backend-tdm
220 %manifest %{name}.manifest
221 %defattr(-,root,root,-)
222 %license LICENSE
223 %{_libdir}/libds-tizen-backend-tdm.so.*
224
225 %files backend-tdm-devel
226 %manifest %{name}.manifest
227 %defattr(-,root,root,-)
228 %license LICENSE
229 %{_includedir}/libds-tizen/backend/tdm.h
230 %{_includedir}/libds-tizen/backend/tdm_output_hwc.h
231 %{_libdir}/pkgconfig/libds-tizen-backend-tdm.pc
232 %{_libdir}/libds-tizen-backend-tdm.so
233 %{_bindir}/tdm-backend
234 %{_bindir}/tinyds-tdm
235 %{_bindir}/tinyds-tdm-hwc
236 %{_bindir}/ds-simple-tbm
237
238 %files tbm-server
239 %manifest %{name}.manifest
240 %defattr(-,root,root,-)
241 %license LICENSE
242 %{_libdir}/libds-tizen-tbm-server.so.*
243
244 %files tbm-server-devel
245 %manifest %{name}.manifest
246 %defattr(-,root,root,-)
247 %license LICENSE
248 %{_includedir}/libds-tizen/tbm_server.h
249 %{_libdir}/pkgconfig/libds-tizen-tbm-server.pc
250 %{_libdir}/libds-tizen-tbm-server.so
251
252 %files keyrouter
253 %manifest %{name}.manifest
254 %defattr(-,root,root,-)
255 %license LICENSE
256 %{_libdir}/libds-tizen-keyrouter.so.*
257
258 %files keyrouter-devel
259 %manifest %{name}.manifest
260 %defattr(-,root,root,-)
261 %license LICENSE
262 %{_includedir}/libds-tizen/keyrouter.h
263 %{_libdir}/pkgconfig/libds-tizen-keyrouter.pc
264 %{_libdir}/libds-tizen-keyrouter.so
265
266 %files input-devicemgr
267 %manifest %{name}.manifest
268 %defattr(-,root,root,-)
269 %license LICENSE
270 %{_libdir}/libds-tizen-input-devicemgr.so.*
271
272 %files input-devicemgr-devel
273 %manifest %{name}.manifest
274 %defattr(-,root,root,-)
275 %license LICENSE
276 %{_includedir}/libds-tizen/input_devicemgr.h
277 %{_libdir}/pkgconfig/libds-tizen-input-devicemgr.pc
278 %{_libdir}/libds-tizen-input-devicemgr.so
279 %{_bindir}/tinyds-tdm-libinput
280 %{_bindir}/input-generator
281
282 %files dpms
283 %manifest %{name}.manifest
284 %defattr(-,root,root,-)
285 %license LICENSE
286 %{_libdir}/libds-tizen-dpms.so.*
287
288 %files dpms-devel
289 %manifest %{name}.manifest
290 %defattr(-,root,root,-)
291 %license LICENSE
292 %{_includedir}/libds-tizen/dpms.h
293 %{_libdir}/pkgconfig/libds-tizen-dpms.pc
294 %{_libdir}/libds-tizen-dpms.so
295 %{_bindir}/tinyds-tdm-dpms
296 %{_bindir}/ds-simple-dpms
297
298 %files indicator
299 %manifest %{name}.manifest
300 %defattr(-,root,root,-)
301 %license LICENSE
302 %{_libdir}/libds-tizen-indicator.so.*
303
304 %files indicator-devel
305 %manifest %{name}.manifest
306 %defattr(-,root,root,-)
307 %license LICENSE
308 %{_includedir}/libds-tizen/indicator.h
309 %{_libdir}/pkgconfig/libds-tizen-indicator.pc
310 %{_libdir}/libds-tizen-indicator.so
311 %{_bindir}/libds-tizen-indicator-tests
312
313 %files clipboard
314 %manifest %{name}.manifest
315 %defattr(-,root,root,-)
316 %license LICENSE
317 %{_libdir}/libds-tizen-clipboard.so.*
318
319 %files clipboard-devel
320 %manifest %{name}.manifest
321 %defattr(-,root,root,-)
322 %license LICENSE
323 %{_includedir}/libds-tizen/clipboard.h
324 %{_libdir}/pkgconfig/libds-tizen-clipboard.pc
325 %{_libdir}/libds-tizen-clipboard.so
326 %{_bindir}/libds-tizen-clipboard-tests
327
328 <<<<<<< HEAD
329 %files launch
330 %manifest %{name}.manifest
331 %defattr(-,root,root,-)
332 %license LICENSE
333 %{_libdir}/libds-tizen-launch.so.*
334
335 %files launch-devel
336 %manifest %{name}.manifest
337 %defattr(-,root,root,-)
338 %license LICENSE
339 %{_includedir}/libds-tizen/launch/appinfo.h
340 %{_libdir}/pkgconfig/libds-tizen-launch.pc
341 %{_libdir}/libds-tizen-launch.so
342 %{_bindir}/libds-tizen-launch-appinfo-tests
343
344 %files display-policy
345 %manifest %{name}.manifest
346 %defattr(-,root,root,-)
347 %license LICENSE
348 %{_libdir}/libds-tizen-display-policy.so.*
349
350 %files display-policy-devel
351 %manifest %{name}.manifest
352 %defattr(-,root,root,-)
353 %license LICENSE
354 %{_includedir}/libds-tizen/display_policy.h
355 %{_libdir}/pkgconfig/libds-tizen-display-policy.pc
356 %{_libdir}/libds-tizen-display-policy.so
357 %{_bindir}/libds-tizen-display-policy-tests