Fix build error--no configure file
[profile/ivi/libdrm.git] / packaging / libdrm.spec
1 Name:       libdrm
2 Summary:    Userspace interface to kernel DRM services -- runtime
3 Version:    2.4.39
4 Release:    1
5 Group:      libs
6 License:    MIT 
7 Source0:    libdrm-%{version}.tar.bz2
8 Patch0:     0001-Adding-slp-subpackage.patch
9 Patch1:     0002-Adding-changes-to-configure.ac.patch
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(pthread-stubs)
14 BuildRequires:  pkgconfig(pciaccess)
15 BuildRequires:  automake
16 BuildRequires:  libtool
17
18
19 %description
20 Userspace interface to kernel DRM services -- runtime
21  This library implements the userspace interface to the kernel DRM
22  services.  DRM stands for "Direct Rendering Manager", which is the
23  kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
24  The DRI is currently used on Linux to provide hardware-accelerated
25  OpenGL drivers.
26  .
27  This package provides the runtime environment for libdrm..
28
29
30
31 %package devel
32 Summary:    Userspace interface to kernel DRM services -- development files
33 Group:      libdevel
34 Requires:   libdrm = %{version}-%{release}
35 Obsoletes:   linux-libc-dev >= 2.6.29
36
37 %description devel
38 Userspace interface to kernel DRM services -- development files
39  This library implements the userspace interface to the kernel DRM
40  services.  DRM stands for "Direct Rendering Manager", which is the
41  kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
42  The DRI is currently used on Linux to provide hardware-accelerated
43  OpenGL drivers.
44  .
45  This package provides the development environment for libdrm..
46
47 %package slp1
48 Summary:        Userspace interface to slp-specific kernel DRM services
49 Group:          Development/Libraries
50
51 %description slp1
52 Userspace interface to slp-specific kernel DRM services
53
54
55 %package -n libkms
56 Summary:    Userspace interface to kernel DRM buffer management
57 Group:      libs
58 Requires(post): /sbin/ldconfig
59 Requires(postun): /sbin/ldconfig
60
61 %description -n libkms
62 Userspace interface to kernel DRM buffer management
63  This library implements a unified userspace interface to the different buffer
64  management interfaces of the kernel DRM hardware drivers..
65
66 %prep
67 %setup -q -n %{name}-%{version}
68
69 %patch0 -p1
70 %patch1 -p1
71
72 %build
73 autoreconf -f --install
74 %configure --disable-static --enable-nouveau-experimental-api
75 make %{?jobs:-j%jobs}
76
77 %install
78 rm -rf %{buildroot}
79 %make_install
80
81 %post -p /sbin/ldconfig
82
83 %postun -p /sbin/ldconfig
84
85 %post -n libkms -p /sbin/ldconfig
86
87 %postun -n libkms -p /sbin/ldconfig
88
89 %files
90 %defattr(-,root,root,-)
91 %{_libdir}/libdrm.so.*
92 %{_libdir}/libdrm_intel.so.*
93 %{_libdir}/libdrm_radeon.so.*
94 %{_libdir}/libdrm_nouveau.so.*
95
96 %files devel
97 %defattr(-,root,root,-)
98 %{_includedir}/libdrm/*
99 %{_includedir}/xf86drmMode.h
100 %{_includedir}/xf86drm.h
101 %{_includedir}/libkms/*
102
103 %{_libdir}/lib*.so
104 %{_libdir}/pkgconfig/*
105
106 %files slp1
107 %{_libdir}/libdrm_slp*.so.*
108
109 %files -n libkms
110 %defattr(-,root,root,-)
111 %{_libdir}/libkms.so.*
112