Add slp changes
[profile/ivi/libdrm.git] / packaging / libdrm.spec
1 Name:       libdrm
2 Summary:    Userspace interface to kernel DRM services -- runtime
3 Version:    2.4.39
4 Release:    1
5 Group:      libs
6 License:    MIT 
7 Source0:    libdrm-%{version}.tar.bz2
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(x11)
11 BuildRequires:  pkgconfig(pthread-stubs)
12 BuildRequires:  pkgconfig(pciaccess)
13 BuildRequires:  automake
14 BuildRequires:  libtool
15
16
17 %description
18 Userspace interface to kernel DRM services -- runtime
19  This library implements the userspace interface to the kernel DRM
20  services.  DRM stands for "Direct Rendering Manager", which is the
21  kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
22  The DRI is currently used on Linux to provide hardware-accelerated
23  OpenGL drivers.
24  .
25  This package provides the runtime environment for libdrm..
26
27
28
29 %package devel
30 Summary:    Userspace interface to kernel DRM services -- development files
31 Group:      libdevel
32 Requires:   libdrm = %{version}-%{release}
33 Obsoletes:   linux-libc-dev >= 2.6.29
34
35 %description devel
36 Userspace interface to kernel DRM services -- development files
37  This library implements the userspace interface to the kernel DRM
38  services.  DRM stands for "Direct Rendering Manager", which is the
39  kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
40  The DRI is currently used on Linux to provide hardware-accelerated
41  OpenGL drivers.
42  .
43  This package provides the development environment for libdrm..
44
45 %package slp1
46 Summary:        Userspace interface to slp-specific kernel DRM services
47 Group:          Development/Libraries
48
49 %description slp1
50 Userspace interface to slp-specific kernel DRM services
51
52
53 %package -n libkms
54 Summary:    Userspace interface to kernel DRM buffer management
55 Group:      libs
56 Requires(post): /sbin/ldconfig
57 Requires(postun): /sbin/ldconfig
58
59 %description -n libkms
60 Userspace interface to kernel DRM buffer management
61  This library implements a unified userspace interface to the different buffer
62  management interfaces of the kernel DRM hardware drivers..
63
64 %prep
65 %setup -q -n %{name}-%{version}
66
67 %build
68 %reconfigure --disable-static --enable-nouveau-experimental-api
69 make %{?jobs:-j%jobs}
70
71 %install
72 rm -rf %{buildroot}
73 %make_install
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %post -n libkms -p /sbin/ldconfig
80
81 %postun -n libkms -p /sbin/ldconfig
82
83 %files
84 %defattr(-,root,root,-)
85 %{_libdir}/libdrm.so.*
86 %{_libdir}/libdrm_intel.so.*
87 %{_libdir}/libdrm_radeon.so.*
88 %{_libdir}/libdrm_nouveau.so.*
89
90 %files devel
91 %defattr(-,root,root,-)
92 %{_includedir}/libdrm/*
93 %{_includedir}/xf86drmMode.h
94 %{_includedir}/xf86drm.h
95 %{_includedir}/libkms/*
96
97 %{_libdir}/lib*.so
98 %{_libdir}/pkgconfig/*
99
100 %files slp1
101 %{_libdir}/libdrm_slp*.so.*
102
103 %files -n libkms
104 %defattr(-,root,root,-)
105 %{_libdir}/libkms.so.*
106