d4e2c7fcb7c11876cdfbf38f7072433d47fb8bf0
[platform/core/system/libdevice-node.git] / packaging / libdevice-node.spec
1 Name:       libdevice-node
2 Summary:    Library to control OAL APIs
3 Version:    0.1.1
4 Release:    1
5 Group:      Application Framework/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(gio-2.0)
14 BuildRequires:  pkgconfig(gmock)
15
16 %description
17 development package of library to control OAL APIs
18
19 %package devel
20 Summary:        Control OAL APIs (devel)
21 Requires:       %{name} = %{version}-%{release}
22
23 %description devel
24 Library to control OAL APIs (devel)
25
26 %package -n device-haltests
27 Summary:        Device HAL(Hardware Abstraction Layer) Test Cases
28 Requires:       %{name} = %{version}-%{release}
29
30 %description -n device-haltests
31 Device HAL(Hardware Abstraction Layer) Test Cases
32
33 %prep
34 %setup -q
35 cp %{SOURCE1} .
36 %build
37 %cmake -DBUILD_GTESTS=on \
38         .
39         #eol
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 %make_install
45
46 %post -p /sbin/ldconfig
47 %postun -p /sbin/ldconfig
48
49 %files
50 %{_libdir}/*.so.*
51 %manifest %{name}.manifest
52 %license LICENSE.APLv2
53
54 %files devel
55 %{_includedir}/device-node/*.h
56 %{_includedir}/hw/*.h
57 %{_libdir}/*.so
58 %{_libdir}/pkgconfig/*.pc
59
60 %files -n device-haltests
61 %{_bindir}/gtest*