Merge branch 'tizen_3.0' into tizen
[platform/core/system/libdevice-node.git] / packaging / libdevice-node.spec
1 Name:       libdevice-node
2 Summary:    Library to control OAL APIs
3 Version:    0.1.1
4 Release:    1
5 Group:      Application Framework/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(glib-2.0)
13
14 %description
15 development package of library to control OAL APIs
16
17 %package devel
18 Summary:        Control OAL APIs (devel)
19 Requires:       %{name} = %{version}-%{release}
20
21 %description devel
22 Library to control OAL APIs (devel)
23
24
25 %prep
26 %setup -q
27 cp %{SOURCE1} .
28 %build
29 %cmake .
30 make %{?jobs:-j%jobs}
31
32 %install
33 %make_install
34
35 %post -p /sbin/ldconfig
36 %postun -p /sbin/ldconfig
37
38 %files
39 %{_libdir}/*.so.*
40 %manifest %{name}.manifest
41 %license LICENSE.APLv2
42
43 %files devel
44 %{_includedir}/device-node/*.h
45 %{_includedir}/hw/*.h
46 %{_libdir}/*.so
47 %{_libdir}/pkgconfig/*.pc