809904f46da704a2f3c8d9aa2f666c834735a4c2
[platform/core/system/libdevice-node.git] / packaging / libdevice-node.spec
1 Name:       libdevice-node
2 Summary:    Library to control OAL APIs
3 Version:    0.1.1
4 Release:    1
5 Group:      Application Framework/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(gio-2.0)
14 BuildRequires:  pkgconfig(gmock)
15 BuildRequires:  pkgconfig(capi-system-info)
16 BuildRequires:  pkgconfig(libsystemd)
17 BuildRequires:  pkgconfig(libusbgx)
18 BuildRequires:  pkgconfig(libsyscommon)
19
20 %description
21 development package of library to control OAL APIs
22
23 %package devel
24 Summary:        Control OAL APIs (devel)
25 Requires:       %{name} = %{version}-%{release}
26
27 %description devel
28 Library to control OAL APIs (devel)
29
30 %package -n device-haltests
31 Summary:        Device HAL(Hardware Abstraction Layer) Test Cases
32 Requires:       %{name} = %{version}-%{release}
33
34 %description -n device-haltests
35 Device HAL(Hardware Abstraction Layer) Test Cases
36
37 %prep
38 %setup -q
39 cp %{SOURCE1} .
40 %build
41 %cmake -DBUILD_GTESTS=on \
42         .
43         #eol
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 %make_install
49
50 %post -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files
54 %manifest %{name}.manifest
55 %license LICENSE.Apache-2.0
56 %{_libdir}/*.so.*
57 %{_unitdir}/mtp-responder-dummy.socket
58 %{_unitdir}/mtp-responder-dummy.service
59 /etc/mtp-responder-dummy/strs
60 /etc/mtp-responder-dummy/descs
61
62 %files devel
63 %manifest %{name}.manifest
64 %license LICENSE.Apache-2.0
65 %{_includedir}/device-node/*.h
66 %{_includedir}/hw/*.h
67 %{_libdir}/*.so
68 %{_libdir}/pkgconfig/*.pc
69
70 %files -n device-haltests
71 %manifest %{name}.manifest
72 %license LICENSE.Apache-2.0
73 %{_bindir}/device_haltests