copy license file to /usr/share/license/
[platform/core/system/libdevice-node.git] / packaging / libdevice-node.spec
1 Name:       libdevice-node
2 Summary:    Library to control OAL APIs
3 Version:    0.1.0
4 Release:    1
5 Group:      Application Framework/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12
13 %description
14 development package of library to control OAL APIs
15
16 %package devel
17 Summary:        Control OAL APIs (devel)
18 Requires:       %{name} = %{version}-%{release}
19
20 %description devel
21 Library to control OAL APIs (devel)
22
23
24 %prep
25 %setup -q
26 cp %{SOURCE1} .
27 %build
28 %cmake .
29 make %{?jobs:-j%jobs}
30
31 %install
32 %make_install
33
34 mkdir -p %{buildroot}%{_datadir}/license
35 cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
36
37 %post -p /sbin/ldconfig
38 %postun -p /sbin/ldconfig
39
40 %files
41 %{_libdir}/*.so.*
42 %{_datadir}/license/%{name}
43 %manifest %{name}.manifest
44
45 %files devel
46 %{_includedir}/device-node/*.h
47 %{_libdir}/*.so
48 %{_libdir}/pkgconfig/*.pc