Add cpp files for HAL test
[platform/core/system/libdevice-node.git] / packaging / libdevice-node.spec
1 Name:       libdevice-node
2 Summary:    Library to control OAL APIs
3 Version:    0.1.1
4 Release:    1
5 Group:      Application Framework/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(gio-2.0)
14 BuildRequires:  pkgconfig(gmock)
15 BuildRequires:  pkgconfig(capi-system-info)
16
17 %description
18 development package of library to control OAL APIs
19
20 %package devel
21 Summary:        Control OAL APIs (devel)
22 Requires:       %{name} = %{version}-%{release}
23
24 %description devel
25 Library to control OAL APIs (devel)
26
27 %package -n device-haltests
28 Summary:        Device HAL(Hardware Abstraction Layer) Test Cases
29 Requires:       %{name} = %{version}-%{release}
30
31 %description -n device-haltests
32 Device HAL(Hardware Abstraction Layer) Test Cases
33
34 %prep
35 %setup -q
36 cp %{SOURCE1} .
37 %build
38 %cmake -DBUILD_GTESTS=on \
39         .
40         #eol
41
42 make %{?jobs:-j%jobs}
43
44 %install
45 %make_install
46
47 %post -p /sbin/ldconfig
48 %postun -p /sbin/ldconfig
49
50 %files
51 %{_libdir}/*.so.*
52 %manifest %{name}.manifest
53 %license LICENSE.APLv2
54
55 %files devel
56 %{_includedir}/device-node/*.h
57 %{_includedir}/hw/*.h
58 %{_libdir}/*.so
59 %{_libdir}/pkgconfig/*.pc
60
61 %files -n device-haltests
62 %{_bindir}/gtest*