Bump to libdatrie 0.2.13
[platform/upstream/libdatrie.git] / packaging / libdatrie.spec
1 Name:           libdatrie
2 Version:        0.2.13
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        Double-Array Trie Library
6 Url:            http://linux.thai.net/~thep/datrie/datrie.html
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 Source1:        Add-pie-compile-option.patch
10 Source2:        Fix_AC_MSG_RESULT_undefied.patch
11 Source99:       baselibs.conf
12 Source1001:     libdatrie.manifest
13
14 BuildRequires:  pkg-config
15
16 %description
17 This is an implementation of double-array structure for representing
18 trie, as proposed by Junichi Aoe.
19
20 Summary:        Double-Array Trie Library
21 Group:          Development/Libraries/C and C++
22
23 %package devel
24 Summary:        Double-Array Trie Library (development)
25 Group:          Development/Libraries/C and C++
26 Requires:       libdatrie = %{version}
27
28 %description devel
29 This is an implementation of double-array structure for representing
30 trie, as proposed by Junichi Aoe.
31
32 This package contains the development files for libdatrie.
33
34 %prep
35 %setup -q
36 cp %{SOURCE1001} .
37 %__patch -p1 < %{SOURCE1}
38 %__patch -p1 < %{SOURCE2}
39
40 %build
41 autoreconf -fi
42
43 chmod +x ./configure
44 %configure \
45         --disable-static --with-pic \
46         --disable-doxygen-doc
47 %__make %{?_smp_mflags}
48
49 %check
50 # %__make check || exit 0
51
52 %install
53 %make_install
54 %remove_docs
55
56 %post  -p /sbin/ldconfig
57
58 %postun  -p /sbin/ldconfig
59
60 %files
61 %manifest %{name}.manifest
62 %license COPYING
63 %{_libdir}/libdatrie.so.1*
64
65 %files devel
66 %manifest %{name}.manifest
67 %license COPYING
68 %{_bindir}/trietool
69 %{_bindir}/trietool-0.2
70 %{_includedir}/datrie/
71 %{_libdir}/libdatrie.so
72 %{_libdir}/pkgconfig/datrie-0.2.pc