Fix license
[platform/upstream/libdatrie.git] / packaging / libdatrie.spec
1
2 %if "%{run_tests}" == "1" 
3     %define __spec_check_pre %___build_pre
4     %define check %%check
5 %endif
6
7 Name:           libdatrie
8 Version:        0.2.10
9 Release:        0
10 License:        LGPL-2.1+
11 Summary:        Double-Array Trie Library
12 Url:            http://linux.thai.net/~thep/datrie/datrie.html
13 Group:          System/Libraries
14 Source:         %{name}-%{version}.tar.bz2
15 Source99:       baselibs.conf
16 Source1001:     libdatrie.manifest
17 BuildRequires:  doxygen
18 BuildRequires:  pkg-config
19
20 %description
21 This is an implementation of double-array structure for representing
22 trie, as proposed by Junichi Aoe.
23
24 Summary:        Double-Array Trie Library
25 Group:          Development/Libraries/C and C++
26
27 %package devel
28 Summary:        Double-Array Trie Library (development)
29 Group:          Development/Libraries/C and C++
30 Requires:       libdatrie = %{version}
31
32 %description devel
33 This is an implementation of double-array structure for representing
34 trie, as proposed by Junichi Aoe.
35
36 This package contains the development files for libdatrie.
37
38 %prep
39 %setup -q
40 cp %{SOURCE1001} .
41
42 %build
43 ./autogen.sh
44 chmod +x ./configure
45 %configure \
46         --disable-static --with-pic \
47         --with-html-docdir=%{_docdir}/libdatrie/html
48 make %{?_smp_mflags}
49
50 %check
51 make check || exit 0
52
53 %install
54 %make_install
55 %remove_docs
56
57 %post  -p /sbin/ldconfig
58
59 %postun  -p /sbin/ldconfig
60
61 %files
62 %manifest %{name}.manifest
63 %defattr(-,root,root)
64 %license COPYING
65 %{_libdir}/libdatrie.so.1*
66
67 %files devel
68 %manifest %{name}.manifest
69 %defattr(-,root,root)
70 %{_bindir}/trietool
71 %{_bindir}/trietool-0.2
72 %{_includedir}/datrie/
73 %{_libdir}/libdatrie.so
74 %{_libdir}/pkgconfig/datrie-0.2.pc