0fb513d5a7031fed8f71f370d04b1db63562f9e7
[platform/upstream/libdatrie.git] / packaging / libdatrie.spec
1 Name:           libdatrie
2 Version:        0.2.4
3 Release:        0
4 License:        LGPL-2.1
5 Summary:        Double-Array Trie Library
6 Url:            http://linux.thai.net/~thep/datrie/datrie.html
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source99:       baselibs.conf
10 Source1001:     libdatrie.manifest
11 BuildRequires:  doxygen
12 BuildRequires:  pkg-config
13
14 %description
15 This is an implementation of double-array structure for representing
16 trie, as proposed by Junichi Aoe.
17
18 Summary:        Double-Array Trie Library
19 Group:          Development/Libraries/C and C++
20
21 %package devel
22 Summary:        Double-Array Trie Library (development)
23 Group:          Development/Libraries/C and C++
24 Requires:       libdatrie = %{version}
25
26 %description devel
27 This is an implementation of double-array structure for representing
28 trie, as proposed by Junichi Aoe.
29
30 This package contains the development files for libdatrie.
31
32 %prep
33 %setup -q
34 cp %{SOURCE1001} .
35
36 %build
37 %configure \
38         --disable-static --with-pic \
39         --with-html-docdir=%{_docdir}/libdatrie/html
40 make %{?_smp_mflags}
41
42 %install
43 %make_install
44 # This is not installed where it should
45 mv %{buildroot}%{_datadir}/doc/libdatrie/README.migration %{buildroot}%{_docdir}/libdatrie/
46
47 %post  -p /sbin/ldconfig
48
49 %postun  -p /sbin/ldconfig
50
51 %files
52 %manifest %{name}.manifest
53 %defattr(-,root,root)
54 %doc COPYING
55 %{_libdir}/libdatrie.so.1*
56
57 %files devel
58 %manifest %{name}.manifest
59 %defattr(-,root,root)
60 %{_bindir}/trietool-0.2
61 %doc %{_mandir}/man*/trietool-0.2.*
62 %{_includedir}/datrie/
63 %{_libdir}/libdatrie.so
64 %{_libdir}/pkgconfig/datrie-0.2.pc
65 %doc %{_docdir}/libdatrie/