resetting manifest requested domain to floor
[platform/upstream/libdaemon.git] / packaging / libdaemon.spec
1 Name:           libdaemon
2 Version:        0.14
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        Lightweight C library That Eases the Writing of UNIX Daemons
6 Url:            http://0pointer.de/lennart/projects/libdaemon/
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 Source1001:     libdaemon.manifest
10 BuildRequires:  doxygen
11 BuildRequires:  pkg-config
12
13 %description
14 libdaemon is a lightweight C library that eases the writing of UNIX
15 daemons.
16
17
18 %package devel
19 License:        GPL-2.0+
20 Summary:        Lightweight C library That Eases the Writing of UNIX Daemons
21 Group:          Development/Libraries/C and C++
22 Requires:       glibc-devel
23 Requires:       libdaemon = %{version}
24
25 %description devel
26 libdaemon is a lightweight C library that eases the writing of UNIX
27 daemons.
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33 %build
34 %configure \
35         --disable-static --with-pic \
36         --disable-lynx
37 make %{?_smp_mflags}
38
39 %install
40 %make_install
41 # We don't care about the HTML README
42 rm %{buildroot}%{_datadir}/doc/libdaemon/{README.html,style.css}
43
44 %post  -p /sbin/ldconfig
45
46 %postun  -p /sbin/ldconfig
47
48 %files -n libdaemon
49 %manifest %{name}.manifest
50 %defattr (-,root,root)
51 %doc LICENSE 
52 %{_libdir}/libdaemon.so.0*
53
54 %files devel
55 %manifest %{name}.manifest
56 %defattr (-,root,root)
57 %{_libdir}/libdaemon.so
58 %{_libdir}/pkgconfig/libdaemon.pc
59 %dir %{_includedir}/libdaemon
60 %{_includedir}/libdaemon/*.h
61
62 %changelog