02b35898c788a408f46208d186d0cc7b232b1236
[platform/upstream/libdaemon.git] / packaging / libdaemon.spec
1 Name:           libdaemon
2 Version:        0.14
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        Lightweight C library That Eases the Writing of UNIX Daemons
6 Url:            http://0pointer.de/lennart/projects/libdaemon/
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 BuildRequires:  doxygen
10 BuildRequires:  pkg-config
11
12 %description
13 libdaemon is a lightweight C library that eases the writing of UNIX
14 daemons.
15
16
17 %package devel
18 License:        GPL-2.0+
19 Summary:        Lightweight C library That Eases the Writing of UNIX Daemons
20 Group:          Development/Libraries/C and C++
21 Requires:       glibc-devel
22 Requires:       libdaemon = %{version}
23
24 %description devel
25 libdaemon is a lightweight C library that eases the writing of UNIX
26 daemons.
27
28 %prep
29 %setup -q
30
31 %build
32 %configure \
33         --disable-static --with-pic \
34         --disable-lynx
35 make %{?_smp_mflags}
36
37 %install
38 %make_install
39 # We don't care about the HTML README
40 rm %{buildroot}%{_datadir}/doc/libdaemon/{README.html,style.css}
41
42 %post  -p /sbin/ldconfig
43
44 %postun  -p /sbin/ldconfig
45
46 %files -n libdaemon
47 %defattr (-,root,root)
48 %doc LICENSE 
49 %{_libdir}/libdaemon.so.0*
50
51 %files devel
52 %defattr (-,root,root)
53 %{_libdir}/libdaemon.so
54 %{_libdir}/pkgconfig/libdaemon.pc
55 %dir %{_includedir}/libdaemon
56 %{_includedir}/libdaemon/*.h
57
58 %changelog