merge with master
[platform/core/security/libcryptsvc.git] / packaging / libcryptsvc.spec
1 Name:      libcryptsvc 
2 Summary:   nothing
3 Version:    0.0.1
4 Release:    4
5 Group:      Osp/Security
6 License:    APLv2
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(openssl)
12
13 %description
14
15 %package devel
16 Summary: nothing
17 Group: Bada/Security
18 Requires: %{name} = %{version}-%{release}
19
20 %description devel
21
22 %prep
23 %setup -q
24
25 %build
26 %ifarch %{ix86}
27 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=x86
28 %else
29 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=arm
30 %endif
31 make %{?jobs:-j%jobs}
32
33 %install
34 rm -rf %{buildroot}
35 mkdir -p %{buildroot}/usr/share/license 
36 cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
37 cp LICENSE.Flora %{buildroot}/usr/share/license/%{name}
38
39 %make_install
40
41 %files
42 %{_libdir}/*.so*
43 %{_datadir}/license/%{name}
44
45 %files devel
46 %{_includedir}/*
47 %{_libdir}/pkgconfig/cryptsvc.pc
48 %{_datadir}/license/%{name}