Add packaging for generating rpm package
[platform/upstream/libconfig.git] / packaging / libconfig.spec
1 Name:            libconfig
2 Summary:         C/C++ configuration file library
3 Version:         1.5.0
4 Release:         0
5 License:         LGPLv2+
6 Group:           Base/Configuration
7
8 Source0:         %{name}-%{version}.tar.gz
9 Source1001:      %{name}.manifest
10 BuildRequires:   bison
11 BuildRequires:   flex
12 BuildRequires:   makeinfo
13
14 %description
15 Libconfig is a library for reading and writing configuration files.
16 Format of configuration files is more readable than XML and library
17 does all the job related to types convesions.
18
19 %package devel
20 Summary:         Development package for libconfig
21 Group:           Development/Libraries
22 Requires:        %{name} = %{version}
23 Requires:        pkgconfig
24
25 %description devel
26 Development libraries for libconfig.
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31 %reconfigure
32
33 %build
34 make
35
36 %install
37 %make_install
38
39 %post -p /sbin/ldconfig
40
41 %postun -p /sbin/ldconfig
42
43 %files
44 %manifest %{name}.manifest
45 %license COPYING.LIB
46 %defattr(-,root,root)
47 %{_libdir}/libconfig*.so.*
48
49 %files devel
50 %manifest %{name}.manifest
51 %defattr(-,root,root)
52 %{_includedir}/libconfig*
53 %{_libdir}/libconfig*.so
54 %{_libdir}/pkgconfig/libconfig*.pc
55 %{_infodir}/libconfig.info*