619e4957a1878d81457d74625485d35953e33005
[framework/appfw/com-core.git] / packaging / libcom-core.spec
1 Name: libcom-core
2 Summary: Library for the light-weight IPC 
3 Version: 0.4.2
4 Release: 1
5 Group: HomeTF/Framework
6 License: Apache License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(glib-2.0)
11
12 %description
13 Light-weight IPC supporting library
14
15 %package devel
16 Summary: Files for using API for light-weight IPC.
17 Group: Development/Libraries
18 Requires: %{name} = %{version}-%{release}
19
20 %description devel
21 Light-weight IPC supporting library (dev)
22
23 %prep
24 %setup -q
25
26 %build
27 %cmake
28 make %{?jobs:-j%jobs}
29
30 %install
31 rm -rf %{buildroot}
32 %make_install
33 mkdir -p %{buildroot}/%{_datarootdir}/license
34
35 %post
36
37 %files -n libcom-core
38 %manifest libcom-core.manifest
39 %defattr(-,root,root,-)
40 %{_libdir}/*.so*
41 %{_datarootdir}/license/*
42
43 %files devel
44 %defattr(-,root,root,-)
45 %{_includedir}/com-core/com-core.h
46 %{_includedir}/com-core/packet.h
47 %{_includedir}/com-core/com-core_packet.h
48 %{_includedir}/com-core/com-core_thread.h
49 %{_includedir}/com-core/secure_socket.h
50 %{_libdir}/pkgconfig/*.pc
51
52 # End of a file