tizen 2.4 release
[framework/telephony/libcall-manager.git] / packaging / libcall-manager.spec
1 %define major 0
2 %define minor 0
3 %define patchlevel 5
4 %define ext_feature 0
5
6 Name:           libcall-manager
7 Version:        %{major}.%{minor}.%{patchlevel}
8 Release:        1
9 License:        Apache-2.0
10 Summary:        Call Manager library
11 Group:          System/Libraries
12 Source0:        %{name}-%{version}.tar.gz
13
14 BuildRequires: cmake
15 BuildRequires: pkgconfig(gio-2.0)
16 BuildRequires: pkgconfig(gio-unix-2.0)
17 BuildRequires: pkgconfig(glib-2.0)
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(vconf)
20 BuildRequires: pkgconfig(capi-system-device)
21 BuildRequires: pkgconfig(capi-base-common)
22 BuildRequires: pkgconfig(capi-system-info)
23 Requires(post): /sbin/ldconfig
24 Requires(postun): /sbin/ldconfig
25
26 %if "%{?tizen_profile_name}" != "mobile"
27 ExcludeArch: %{arm} %ix86 x86_64
28 %endif
29
30 %description
31 Call Manager Library
32
33 %package devel
34 Summary: Call Manager API library (devel)
35 Group: Development/Libraries
36 Requires: %{name} = %{version}-%{release}
37
38 %description devel
39 Call Manager API library (devel)
40
41 %prep
42 %setup -q
43
44 %build
45 export LDFLAGS+=" -Wl,-z,nodelete "
46
47 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DVERSION=%{version} \
48 %if 0%{?ext_feature}
49 -D_ENABLE_EXT_FEATURE:BOOL=ON \
50 %else
51 -D_ENABLE_EXT_FEATURE:BOOL=OFF \
52 %endif
53
54 make %{?_smp_mflags}
55
56 %install
57 %make_install
58
59 mkdir -p %{buildroot}/usr/share/license
60 cp LICENSE %{buildroot}/usr/share/license/libcall-manager
61
62 %post
63
64 %postun -p /sbin/ldconfig
65
66 %files
67 %manifest libcall-manager.manifest
68 %defattr(644,system,system,-)
69 %{_datadir}/license/libcall-manager
70 %attr(755,system,system) %{_bindir}/cm-test
71 %{_libdir}/*.so.*
72
73 %files devel
74 # callmgr client
75 %defattr(644,system,system,-)
76 %{_libdir}/libcall-manager.so
77 %{_includedir}/call-manager/*
78 %{_libdir}/pkgconfig/callmgr_client.pc
79