"Removed spectacle comments from .spec"
[profile/ivi/libasyncns.git] / packaging / libasyncns.spec
1 Name:       libasyncns
2 Summary:    Asynchronous Name Service Library
3 Version:    0.7
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://0pointer.de/lennart/projects/libasyncns
8 Source0:    http://0pointer.de/lennart/projects/libasyncns/libasyncns-%{version}.tar.gz
9 Source100:  libasyncns.yaml
10 Requires(post):  /sbin/ldconfig
11 Requires(postun):  /sbin/ldconfig
12
13 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
14
15 %description
16 Description: %{summary}
17
18
19 %package devel
20 Summary:    Development components for the libasyncns library
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25 Description: %{summary}
26
27
28 %prep
29 %setup -q -n %{name}-%{version}
30
31 %build
32
33 %configure --disable-static \
34     --disable-rpath
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42
43 %clean
44 rm -rf %{buildroot}
45
46 %post -p /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50
51
52 %files
53 %defattr(-,root,root,-)
54 %doc README LICENSE
55 %{_libdir}/libasyncns.so.*
56 %doc /usr/share/doc/libasyncns
57
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/asyncns.h
62 %{_libdir}/libasyncns.so
63 %{_libdir}/pkgconfig/libasyncns.pc
64