libXxf86dga should not try to build into a pure wayland platform.
[platform/upstream/libXxf86dga.git] / packaging / libXxf86dga.spec
1 %bcond_with x
2
3 Name:           libXxf86dga
4 Version:        1.1.3
5 Release:        1
6 License:        MIT
7 Summary:        X.Org X11 libXxf86dga runtime library
8 URL:            http://www.x.org
9 Group:          System/Libraries
10 Source:         %{name}-%{version}.tar.gz
11 Source1001:     libXxf86dga.manifest
12 BuildRequires:  pkgconfig(xorg-macros)
13 BuildRequires:  pkgconfig(xf86dgaproto)
14 BuildRequires:  pkgconfig(x11)
15 BuildRequires:  pkgconfig(xext)
16
17 %if !%{with x}
18 ExclusiveArch:
19 %endif
20
21 %description
22 X.Org X11 libXxf86dga runtime library
23
24 %package devel
25 Summary:        X.Org X11 libXxf86dga development package
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}
28 Provides:       libxxf86dga-devel
29
30 %description devel
31 X.Org X11 libXxf86dga development package
32
33 %prep
34 %setup -q
35 cp %{SOURCE1001} .
36
37 %build
38 %configure
39
40 make %{?_smp_mflags}
41
42 %install
43 %make_install
44
45 %remove_docs
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51 %files
52 %manifest %{name}.manifest
53 %license COPYING
54 %{_libdir}/libXxf86dga.so.1
55 %{_libdir}/libXxf86dga.so.1.0.0
56
57 %files devel
58 %manifest %{name}.manifest
59 %{_libdir}/libXxf86dga.so
60 %{_libdir}/pkgconfig/xxf86dga.pc
61 %{_includedir}/X11/extensions/xf86dga1.h
62 %{_includedir}/X11/extensions/Xxf86dga.h