e6220b26403f2e1f851748ff3f0dcbc768f93f3c
[framework/uifw/xorg/lib/libxtst.git] / packaging / libXtst.spec
1 Summary: X.Org X11 libXtst runtime library
2 Name: libXtst
3 Version: 1.2.0
4 Release: 3
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires:  pkgconfig(xorg-macros)
12 BuildRequires:  pkgconfig(xproto)
13 BuildRequires:  pkgconfig(xextproto)
14 BuildRequires:  pkgconfig(randrproto)
15 BuildRequires:  pkgconfig(inputproto)
16 BuildRequires:  pkgconfig(recordproto)
17 BuildRequires:  pkgconfig(xextproto)
18 BuildRequires: libX11-devel
19 BuildRequires: libXext-devel
20 BuildRequires: libXi-devel
21
22 %description
23 X.Org X11 libXtst runtime library
24
25 %package devel
26 Summary: X.Org X11 libXtst development package
27 Group: Development/Libraries
28 Requires: %{name} = %{version}-%{release}
29 Requires: libXi-devel
30 Provides: libxtst-devel
31
32 %description devel
33 X.Org X11 libXtst development package
34
35 %prep
36 %setup -q
37
38 # Disable static library creation by default.
39 %define with_static 0
40
41 %build
42
43 %reconfigure --disable-static \
44                LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 make install DESTDIR=$RPM_BUILD_ROOT
51
52 # We intentionally don't ship *.la files
53 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
54
55 rm -rf $RPM_BUILD_ROOT%{_docdir}
56
57 %remove_docs
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(-,root,root,-)
67 %doc COPYING ChangeLog
68 %{_libdir}/libXtst.so.6
69 %{_libdir}/libXtst.so.6.1.0
70
71 %files devel
72 %defattr(-,root,root,-)
73 #%doc specs/*.txt
74 %{_includedir}/X11/extensions/XTest.h
75 %{_includedir}/X11/extensions/record.h
76 %if %{with_static}
77 %{_libdir}/libXtst.a
78 %endif
79 %{_libdir}/libXtst.so
80 %{_libdir}/pkgconfig/xtst.pc
81 #%{_mandir}/man3/XTest*.3*