libXpm should not try to build into a pure wayland platform.
[platform/upstream/libXpm.git] / packaging / libXpm.spec
1 %bcond_with x
2
3 Name:           libXpm
4 Version:        3.5.10
5 Release:        1
6 License:        MIT
7 Summary:        XPM format pixmap library
8 Url:            http://www.x.org
9 Group:          Graphics/X Window System
10
11 Source:         %{name}-%{version}.tar.bz2
12 Source1001:     libXpm.manifest
13
14 BuildRequires:  gettext
15 BuildRequires:  pkgconfig(xau)
16 BuildRequires:  pkgconfig(xext)
17 BuildRequires:  pkgconfig(xorg-macros)
18 BuildRequires:  pkgconfig(xproto)
19 BuildRequires:  pkgconfig(xt)
20
21 %if !%{with x}
22 ExclusiveArch:
23 %endif
24
25 %description
26 X.Org X11 libXpm runtime library
27
28 %package devel
29 Summary:        XPM format pixmap library
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}
32 Provides:       libxpm-devel
33
34 %description devel
35 X.Org X11 libXpm development package
36
37 %prep
38 %setup -q
39 cp %{SOURCE1001} .
40
41 %build
42 %configure --disable-static
43 make %{?_smp_mflags}
44
45 %install
46 %make_install
47
48 %remove_docs
49
50 %post -p /sbin/ldconfig
51
52 %postun -p /sbin/ldconfig
53
54 %files
55 %manifest %{name}.manifest
56 %defattr(-,root,root,-)
57 %license COPYING
58 %{_libdir}/libXpm.so.4
59 %{_libdir}/libXpm.so.4.11.0
60
61 %files devel
62 %manifest %{name}.manifest
63 %defattr(-,root,root,-)
64 %{_bindir}/cxpm
65 %{_bindir}/sxpm
66 %{_includedir}/X11/xpm.h
67 %{_libdir}/libXpm.so
68 %{_libdir}/pkgconfig/xpm.pc