libXgesture should not try to build into a pure wayland platform.
[platform/upstream/libXgesture.git] / packaging / libXgesture.spec
1 %bcond_with x
2
3 Name:   libXgesture
4 Summary:    X11 Gesture Extension library
5 Version: 0.1.0
6 Release:    2
7 Group:      System/Libraries
8 License:    MIT
9 URL:        http://www.x.org
10 Source0:    %{name}-%{version}.tar.gz
11 Source1001:     libXgesture.manifest
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(xext)
14 BuildRequires:  pkgconfig(xproto)
15 BuildRequires:  pkgconfig(xextproto)
16 BuildRequires:  pkgconfig(gestureproto)
17 BuildRequires:  pkgconfig(xorg-macros)
18
19 %if !%{with x}
20 ExclusiveArch:
21 %endif
22
23 %description
24 X.Org X11 libXt library
25
26
27 %package devel
28 Summary:    X11 Gesture Extension library (development headers)
29 Group:      Development/Libraries
30 Provides: libxgesture-devel
31 Requires:   %{name} = %{version}-%{release}
32 Requires:   pkgconfig(x11)
33 Requires:   pkgconfig(xext)
34 Requires:   pkgconfig(gestureproto)
35
36 %description devel
37 libXgesture provides an X Window System client interface to the X Gesture
38 Extension to the X protocol.
39
40
41 %prep
42 %setup -q
43 cp %{SOURCE1001} .
44
45 %build
46 %reconfigure --disable-static
47 make %{?jobs:-j%jobs}
48
49 %install
50 rm -rf %{buildroot}
51 %make_install
52
53 %post -p /sbin/ldconfig
54
55 %postun -p /sbin/ldconfig
56
57
58 %files
59 %manifest %{name}.manifest
60 %license COPYING
61 %{_libdir}/libXgesture.so.*
62
63 %files devel
64 %manifest %{name}.manifest
65 %{_includedir}/X11/extensions/*
66 %{_libdir}/libXgesture.so
67 %{_libdir}/pkgconfig/xgesture.pc