libXfontcache should not try to build into a pure wayland platform.
[platform/upstream/libXfontcache.git] / packaging / libXfontcache.spec
1 %bcond_with x
2
3 Name:           libXfontcache
4 Version:        1.0.5
5 Release:        0
6 Summary:        X TrueType font cache extension client library
7 License:        MIT
8 Group:          Development/Libraries
9 Url:            http://xorg.freedesktop.org/
10
11 Source:         %name-%version.tar.bz2
12 Source1001:     libXfontcache.manifest
13 BuildRequires:  fdupes
14 BuildRequires:  pkgconfig
15 BuildRequires:  pkgconfig(fontcacheproto)
16 BuildRequires:  pkgconfig(x11)
17 BuildRequires:  pkgconfig(xext)
18 BuildRequires:  pkgconfig(xextproto)
19 BuildRequires:  pkgconfig(xorg-macros) >= 1.3
20
21 %if !%{with x}
22 ExclusiveArch:
23 %endif
24
25 %description
26 FontCache is an extension that is used by X TrueType to cache
27 information about fonts.
28
29 %package devel
30 Summary:        Development files for the X TrueType font cache library
31 Group:          Development/Libraries
32 Requires:       %name = %version
33
34 %description devel
35 FontCache is an extension that is used by X TrueType to cache
36 information about fonts.
37
38 This package contains the development headers for the library found
39 in %name.
40
41 %prep
42 %setup -q
43 cp %{SOURCE1001} .
44
45 %build
46 %configure --disable-static
47 make %{?_smp_mflags}
48
49 %install
50 %make_install
51 %fdupes %buildroot
52
53 %post  -p /sbin/ldconfig
54
55 %postun -p /sbin/ldconfig
56
57 %files
58 %manifest %{name}.manifest
59 %defattr(-,root,root)
60 %license COPYING
61 %_libdir/libXfontcache.so.1*
62
63 %files devel
64 %manifest %{name}.manifest
65 %defattr(-,root,root)
66 %_libdir/libXfontcache.so
67 %_libdir/pkgconfig/xfontcache.pc
68 %_mandir/man3/*
69
70 %changelog