add packaging
[platform/upstream/libXdmcp.git] / packaging / libXdmcp.spec
1 Name:           libXdmcp
2 Version:        1.1.1
3 Release:        1
4 License:        MIT
5 Summary:        X Display Manager Control Protocol library
6 Url:            http://www.x.org
7 Group:          System Environment/Libraries
8
9 Source:         %{name}-%{version}.tar.bz2
10
11 BuildRequires:  pkgconfig(xorg-macros)
12 BuildRequires:  pkgconfig(xproto)
13
14 %description
15 X Display Manager Control Protocol library.
16
17 %package devel
18 Summary:        Development files for %{name}
19 Group:          Development/Libraries
20 Requires:       %{name} = %{version}
21 Provides:       libxdmcp-devel
22
23 %description devel
24 libXdmcp development package.
25
26 %prep
27 %setup -q
28
29 %build
30 %reconfigure --disable-static \
31            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
32 make %{?_smp_mflags}
33
34 %install
35
36 make install DESTDIR=%{buildroot} INSTALL="install -p"
37
38 # We intentionally don't ship *.la files
39 rm -f %{buildroot}%{_libdir}/*.la
40
41 # manual fixup later
42 rm -rf %{buildroot}%{_docdir}
43
44 %remove_docs
45
46 %post -p /sbin/ldconfig
47 %postun -p /sbin/ldconfig
48
49 %files
50 %defattr(-,root,root,-)
51 %doc AUTHORS COPYING ChangeLog Wraphelp.README.crypto
52 %{_libdir}/libXdmcp.so.6
53 %{_libdir}/libXdmcp.so.6.0.0
54
55 %files devel
56 %defattr(-,root,root,-)
57 %{_includedir}/X11/Xdmcp.h
58 %{_libdir}/libXdmcp.so
59 %{_libdir}/pkgconfig/xdmcp.p