add %bcond_with x to build for X
[platform/upstream/libXdmcp.git] / packaging / libXdmcp.spec
1 %bcond_with x
2
3 Name:           libXdmcp
4 Version:        1.1.1
5 Release:        1
6 License:        MIT
7 Summary:        X Display Manager Control Protocol library
8 Url:            http://www.x.org
9 Group:          Graphics/X Window System
10
11 Source:         %{name}-%{version}.tar.bz2
12 Source1001:     libXdmcp.manifest
13
14 BuildRequires:  pkgconfig(xorg-macros)
15 BuildRequires:  pkgconfig(xproto)
16
17 %if !%{with x}
18 ExclusiveArch:
19 %endif
20
21 %description
22 X Display Manager Control Protocol library.
23
24 %package devel
25 Summary:        Development files for %{name}
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}
28
29 %description devel
30 libXdmcp development package.
31
32 %prep
33 %setup -q
34 cp %{SOURCE1001} .
35
36 %build
37 %reconfigure --disable-static 
38 make %{?_smp_mflags}
39
40 %install
41 %make_install
42
43 %remove_docs
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49 %files
50 %manifest %{name}.manifest
51 %defattr(-,root,root,-)
52 %license COPYING 
53 %{_libdir}/libXdmcp.so.6
54 %{_libdir}/libXdmcp.so.6.0.0
55
56 %files devel
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %{_includedir}/X11/Xdmcp.h
60 %{_libdir}/libXdmcp.so
61 %{_libdir}/pkgconfig/xdmcp.pc