libXaw should not try to build into a pure wayland platform.
[platform/upstream/libXaw.git] / packaging / libXaw.spec
1 %bcond_with x
2
3 Name:           libXaw
4 Version:        1.0.11
5 Release:        1
6 License:        MIT
7 Summary:        X Athena Widget Set
8 Url:            http://www.x.org
9 Group:          Graphics/X Window System
10 Source:         %{name}-%{version}.tar.bz2
11 Source1001:     libXaw.manifest
12 BuildRequires:  ed
13 BuildRequires:  pkgconfig(x11)
14 BuildRequires:  pkgconfig(xext)
15 BuildRequires:  pkgconfig(xmu)
16 BuildRequires:  pkgconfig(xorg-macros)
17 BuildRequires:  pkgconfig(xpm)
18 BuildRequires:  pkgconfig(xproto)
19 BuildRequires:  pkgconfig(xt)
20
21 %if !%{with x}
22 ExclusiveArch:
23 %endif
24
25 %description
26 Xaw is a widget set based on the X Toolkit Intrinsics (Xt) Library.
27
28 %package devel
29 Summary:        Development files for %{name}
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}
32 Requires:       pkgconfig
33 Requires:       pkgconfig(xmu)
34 Requires:       pkgconfig(xpm)
35 Requires:       pkgconfig(xproto)
36 Requires:       pkgconfig(xt)
37
38 %description devel
39 X.Org X11 libXaw development package
40
41 %prep
42 %setup -q
43 cp %{SOURCE1001} .
44
45 %build
46 export CFLAGS="${CFLAGS} %{optflags} -Os"
47 %reconfigure \
48                --disable-xaw8 --disable-static \
49                --disable-xaw6
50 make %{?_smp_mflags}
51
52 %install
53
54 make install DESTDIR=%{buildroot} INSTALL="install -p"
55 rm -f %{buildroot}%{_libdir}/*.la
56
57 %remove_docs
58
59 %post -p /sbin/ldconfig
60 %postun -p /sbin/ldconfig
61
62 %files
63 %manifest %{name}.manifest
64 %defattr(-,root,root,-)
65 %license COPYING
66 %{_libdir}/libXaw.so.7
67 %{_libdir}/libXaw7.so.7
68 %{_libdir}/libXaw7.so.7.0.0
69
70 %files devel
71 %manifest %{name}.manifest
72 %defattr(-,root,root,-)
73 %dir %{_includedir}/X11/Xaw
74 %{_includedir}/X11/Xaw/*.h
75 # FIXME:  Is this C file really supposed to be here?
76 %{_includedir}/X11/Xaw/Template.c
77 %{_libdir}/libXaw.so
78 %{_libdir}/libXaw7.so
79 %{_libdir}/pkgconfig/xaw7.pc