upload tizen2.0 source
[framework/uifw/xorg/lib/libxau.git] / packaging / libXau.spec
1 Name:    libXau
2 Summary: X.Org X11 libXau runtime library
3 Version: 1.0.7
4 Release: 1
5 Group:   System/Libraries
6 License: MIT
7 URL:     http://www.x.org/
8 Source0: http://xorg.freedesktop.org/releases/individual/lib/%{name}-%{version}.tar.gz
9
10 BuildRequires:  pkgconfig(xproto)
11 BuildRequires:  pkgconfig(xorg-macros)
12
13 Requires(post):   /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
17
18 %description
19 Description: %{summary}
20 This is a very simple mechanism for providing individual access to an X Window
21 System display.It uses existing core protocol and library hooks for specifying
22 authorization data in the connection setup block to restrict use of the display
23 to only those clients that show that they know a server-specific key
24 called a "magic cookie".
25
26 %package devel
27 Summary:  Development components for the libXau library
28 Group:    Development/Libraries
29 Requires: %{name} = %{version}-%{release}
30 Provides: libxau-devel
31
32 %description devel
33 Description: %{summary}
34
35
36 %prep
37 %setup -q
38
39
40 %build
41
42 ./autogen.sh
43 %reconfigure --disable-static
44
45 # Call make instruction with smp support
46 make %{?jobs:-j%jobs}
47
48 %install
49 rm -rf %{buildroot}
50 %make_install
51
52 # remove *.la files
53 rm -f %{buildroot}%{_libdir}/*.la
54
55 %remove_docs
56
57 %clean
58 rm -rf %{buildroot}
59
60 %post   -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files
64 %defattr(-,root,root,-)
65 %{_libdir}/*.so.*
66
67 %files devel
68 %defattr(-,root,root,-)
69 %dir %{_includedir}/X11
70 %{_includedir}/X11/*.h
71 %{_libdir}/*.so
72 %{_libdir}/pkgconfig/*.pc