f1bbc63118f2775b6de3a2989a71d8fc58b2cda4
[framework/uifw/xorg/lib/libx11.git] / packaging / libX11.spec
1 %define tarball libX11
2 #define gitdate 20090805
3
4 Summary: Core X11 protocol client library
5 Name: libX11
6 Version: 1.5.0
7 Release: 2
8 License: MIT
9 Group: System Environment/Libraries
10 URL: http://www.x.org
11
12 Source0: %{name}-%{version}.tar.gz
13
14 BuildRequires:  pkgconfig(xcmiscproto)
15 BuildRequires:  pkgconfig(bigreqsproto)
16 BuildRequires:  pkgconfig(kbproto)
17 BuildRequires:  pkgconfig(inputproto)
18 BuildRequires:  pkgconfig(xorg-macros)
19 BuildRequires:  pkgconfig(xextproto)
20 BuildRequires:  pkgconfig(xproto) >= 7.0.15
21 BuildRequires:  xorg-x11-xtrans-devel >= 1.0.3-4
22 BuildRequires:  libxcb-devel >= 1.2
23 BuildRequires:  pkgconfig(xau) pkgconfig(xdmcp)
24 BuildRequires:  perl(Pod::Simple)
25 BuildRequires:  perl(Pod::Escapes)
26 Requires:       perl
27 Requires: %{name}-common = %{version}-%{release}
28 Provides: libx11
29
30 %description
31 Core X11 protocol client library.
32
33 %package common
34 Summary: Common data for libX11
35 Group: System Environment/Libraries
36 BuildArch: noarch
37
38 %description common
39 libX11 common data
40
41 %package devel
42 Summary: Development files for %{name}
43 Group: Development/Libraries
44 Requires: %{name} = %{version}-%{release}
45 Provides: libx11-devel
46
47 %description devel
48 X.Org X11 libX11 development package
49
50 %prep
51 %setup -q
52
53
54 %build
55 # sodding libtool
56 autoreconf -v --install --force
57 %reconfigure --disable-static \
58            --enable-specs \
59            --enable-man-pages=3 \
60            --with-xcb=yes \
61            CFLAGS="${CFLAGS} " \
62            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
63
64 make %{?jobs:-j%jobs}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
70
71 # We intentionally don't ship *.la files
72 find $RPM_BUILD_ROOT -type f -name '*.la' -delete
73
74 # FIXME: Don't install Xcms.txt - find out why upstream still ships this.
75 find $RPM_BUILD_ROOT -name 'Xcms.txt' -delete
76
77 # FIXME package these properly
78 rm -rf $RPM_BUILD_ROOT%{_docdir}
79
80 %remove_docs
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(-,root,root,-)
90 %{_libdir}/libX11.so.6
91 %{_libdir}/libX11.so.6.3.0
92 %{_libdir}/libX11-xcb.so.1
93 %{_libdir}/libX11-xcb.so.1.0.0
94
95 %files common
96 %defattr(-,root,root,-)
97 %doc AUTHORS COPYING README NEWS
98 %{_datadir}/X11/locale/*
99 %{_datadir}/X11/XErrorDB
100
101 %files devel
102 %defattr(-,root,root,-)
103 %{_includedir}/X11/ImUtil.h
104 %{_includedir}/X11/XKBlib.h
105 %{_includedir}/X11/Xcms.h
106 %{_includedir}/X11/Xlib.h
107 %{_includedir}/X11/XlibConf.h
108 %{_includedir}/X11/Xlibint.h
109 %{_includedir}/X11/Xlib-xcb.h
110 %{_includedir}/X11/Xlocale.h
111 %{_includedir}/X11/Xregion.h
112 %{_includedir}/X11/Xresource.h
113 %{_includedir}/X11/Xutil.h
114 %{_includedir}/X11/cursorfont.h
115 %{_libdir}/libX11.so
116 %{_libdir}/libX11-xcb.so
117 %{_libdir}/pkgconfig/x11.pc
118 %{_libdir}/pkgconfig/x11-xcb.pc
119 #%{_mandir}/man3/*.3*
120 #%{_mandir}/man5/*.5*