Tizen 2.1 base
[framework/uifw/xorg/lib/libx11.git] / packaging / libX11.spec
1 %define tarball libX11
2 #define gitdate 20090805
3
4 Summary: Core X11 protocol client library
5 Name: libX11
6 Version: 1.5.0
7 Release: 2
8 License: MIT
9 Group: System Environment/Libraries
10 URL: http://www.x.org
11
12 Source0: %{name}-%{version}.tar.gz
13
14 BuildRequires:  pkgconfig(xcmiscproto)
15 BuildRequires:  pkgconfig(bigreqsproto)
16 BuildRequires:  pkgconfig(kbproto)
17 BuildRequires:  pkgconfig(inputproto)
18 BuildRequires:  pkgconfig(xorg-macros)
19 BuildRequires:  pkgconfig(xextproto)
20 BuildRequires: pkgconfig(xproto) >= 7.0.15
21 BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-4
22 BuildRequires: libxcb-devel >= 1.2
23 BuildRequires: pkgconfig(xau) pkgconfig(xdmcp)
24
25 Requires: %{name}-common = %{version}-%{release}
26 Provides: libx11
27
28 %description
29 Core X11 protocol client library.
30
31 %package common
32 Summary: Common data for libX11
33 Group: System Environment/Libraries
34 BuildArch: noarch
35
36 %description common
37 libX11 common data
38
39 %package devel
40 Summary: Development files for %{name}
41 Group: Development/Libraries
42 Requires: %{name} = %{version}-%{release}
43 Provides: libx11-devel
44
45 %description devel
46 X.Org X11 libX11 development package
47
48 %prep
49 %setup -q
50
51
52 %build
53 # sodding libtool
54 autoreconf -v --install --force
55 %reconfigure --disable-static \
56            --enable-specs \
57            --enable-man-pages=3 \
58            --with-xcb=yes \
59            CFLAGS="${CFLAGS} " \
60            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
61
62 make %{?jobs:-j%jobs}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 mkdir -p %{buildroot}/usr/share/license
67 cp -af COPYING %{buildroot}/usr/share/license/%{name}
68 cp -af COPYING %{buildroot}/usr/share/license/%{name}-common
69 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
70
71 # We intentionally don't ship *.la files
72 find $RPM_BUILD_ROOT -type f -name '*.la' -delete
73
74 # FIXME: Don't install Xcms.txt - find out why upstream still ships this.
75 find $RPM_BUILD_ROOT -name 'Xcms.txt' -delete
76
77 # FIXME package these properly
78 rm -rf $RPM_BUILD_ROOT%{_docdir}
79
80 %remove_docs
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(-,root,root,-)
90 /usr/share/license/%{name}
91 %{_libdir}/libX11.so.6
92 %{_libdir}/libX11.so.6.3.0
93 %{_libdir}/libX11-xcb.so.1
94 %{_libdir}/libX11-xcb.so.1.0.0
95
96 %files common
97 %defattr(-,root,root,-)
98 /usr/share/license/%{name}-common
99 #%doc AUTHORS COPYING README NEWS
100 %{_datadir}/X11/locale/*
101 %{_datadir}/X11/XErrorDB
102
103 %files devel
104 %defattr(-,root,root,-)
105 %{_includedir}/X11/ImUtil.h
106 %{_includedir}/X11/XKBlib.h
107 %{_includedir}/X11/Xcms.h
108 %{_includedir}/X11/Xlib.h
109 %{_includedir}/X11/XlibConf.h
110 %{_includedir}/X11/Xlibint.h
111 %{_includedir}/X11/Xlib-xcb.h
112 %{_includedir}/X11/Xlocale.h
113 %{_includedir}/X11/Xregion.h
114 %{_includedir}/X11/Xresource.h
115 %{_includedir}/X11/Xutil.h
116 %{_includedir}/X11/cursorfont.h
117 %{_libdir}/libX11.so
118 %{_libdir}/libX11-xcb.so
119 %{_libdir}/pkgconfig/x11.pc
120 %{_libdir}/pkgconfig/x11-xcb.pc
121 #%{_mandir}/man3/*.3*
122 #%{_mandir}/man5/*.5*