Initialize Tizen 2.3
[framework/uifw/xorg/lib/libx11.git] / packaging / libX11.spec
1 %define tarball libX11
2 #define gitdate 20090805
3
4 Summary: Core X11 protocol client library
5 Name: libX11
6 Version: 1.5.0
7 Release: 3
8 VCS:     framework/uifw/xorg/lib/libx11#REBASE-7-g234d56c50c5d38bc7d55b573fb94ec4d84ed4b3d
9 License: MIT
10 Group: System Environment/Libraries
11 URL: http://www.x.org
12
13 Source0: %{name}-%{version}.tar.gz
14
15 BuildRequires:  pkgconfig(xcmiscproto)
16 BuildRequires:  pkgconfig(bigreqsproto)
17 BuildRequires:  pkgconfig(kbproto)
18 BuildRequires:  pkgconfig(inputproto)
19 BuildRequires:  pkgconfig(xorg-macros)
20 BuildRequires:  pkgconfig(xextproto)
21 BuildRequires: pkgconfig(xproto) >= 7.0.15
22 BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-4
23 BuildRequires: libxcb-devel >= 1.2
24
25 Requires: %{name}-common = %{version}-%{release}
26 Provides: libx11
27
28 %description
29 Core X11 protocol client library.
30
31 %package common
32 Summary: Common data for libX11
33 Group: System Environment/Libraries
34 BuildArch: noarch
35
36 %description common
37 libX11 common data
38
39 %package devel
40 Summary: Development files for %{name}
41 Group: Development/Libraries
42 Requires: %{name} = %{version}-%{release}
43 Provides: libx11-devel
44
45 %description devel
46 X.Org X11 libX11 development package
47
48 %prep
49 %setup -q
50
51
52 %build
53 # sodding libtool
54 autoreconf -v --install --force
55 %reconfigure --disable-static \
56            --enable-specs \
57            --enable-man-pages=3 \
58            --with-xcb=yes \
59            CFLAGS="${CFLAGS} -D_F_REDUCE_SYSCALL " \
60            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
61
62 make %{?jobs:-j%jobs}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 mkdir -p %{buildroot}/usr/share/license
67 cp -af COPYING %{buildroot}/usr/share/license/%{name}
68 cp -af COPYING %{buildroot}/usr/share/license/%{name}-common
69 cp -af COPYING %{buildroot}/usr/share/license/%{name}-devel
70 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
71
72 # We intentionally don't ship *.la files
73 find $RPM_BUILD_ROOT -type f -name '*.la' -delete
74
75 # FIXME: Don't install Xcms.txt - find out why upstream still ships this.
76 find $RPM_BUILD_ROOT -name 'Xcms.txt' -delete
77
78 # FIXME package these properly
79 rm -rf $RPM_BUILD_ROOT%{_docdir}
80
81 %remove_docs
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(-,root,root,-)
91 /usr/share/license/%{name}
92 %{_libdir}/libX11.so.6
93 %{_libdir}/libX11.so.6.3.0
94 %{_libdir}/libX11-xcb.so.1
95 %{_libdir}/libX11-xcb.so.1.0.0
96
97 %files common
98 %defattr(-,root,root,-)
99 /usr/share/license/%{name}-common
100 #%doc AUTHORS COPYING README NEWS
101 %{_datadir}/X11/locale/*
102 %{_datadir}/X11/XErrorDB
103
104 %files devel
105 %defattr(-,root,root,-)
106 %{_includedir}/X11/ImUtil.h
107 %{_includedir}/X11/XKBlib.h
108 %{_includedir}/X11/Xcms.h
109 %{_includedir}/X11/Xlib.h
110 %{_includedir}/X11/XlibConf.h
111 %{_includedir}/X11/Xlibint.h
112 %{_includedir}/X11/Xlib-xcb.h
113 %{_includedir}/X11/Xlocale.h
114 %{_includedir}/X11/Xregion.h
115 %{_includedir}/X11/Xresource.h
116 %{_includedir}/X11/Xutil.h
117 %{_includedir}/X11/cursorfont.h
118 %{_libdir}/libX11.so
119 %{_libdir}/libX11-xcb.so
120 %{_libdir}/pkgconfig/x11.pc
121 %{_libdir}/pkgconfig/x11-xcb.pc
122 #%{_mandir}/man3/*.3*
123 #%{_mandir}/man5/*.5*
124 /usr/share/license/%{name}-devel