Add .changes file and remove an extraneous dependency
[framework/uifw/xorg/lib/libx11.git] / packaging / libX11.spec
1 %define tarball libX11
2 #define gitdate 20090805
3
4 Summary: Core X11 protocol client library
5 Name: libX11
6 Version: 1.5.0
7 Release: 2
8 License: MIT
9 Group: System Environment/Libraries
10 URL: http://www.x.org
11
12 Source0: %{name}-%{version}.tar.gz
13
14 BuildRequires:  pkgconfig(xcmiscproto)
15 BuildRequires:  pkgconfig(bigreqsproto)
16 BuildRequires:  pkgconfig(kbproto)
17 BuildRequires:  pkgconfig(inputproto)
18 BuildRequires:  pkgconfig(xorg-macros)
19 BuildRequires:  pkgconfig(xextproto)
20 BuildRequires:  pkgconfig(xproto) >= 7.0.15
21 BuildRequires:  xorg-x11-xtrans-devel >= 1.0.3-4
22 BuildRequires:  libxcb-devel >= 1.2
23 BuildRequires:  pkgconfig(xau) pkgconfig(xdmcp)
24 BuildRequires:  perl(Pod::Simple)
25 BuildRequires:  perl(Pod::Escapes)
26 Requires: %{name}-common = %{version}-%{release}
27 Provides: libx11
28
29 %description
30 Core X11 protocol client library.
31
32 %package common
33 Summary: Common data for libX11
34 Group: System Environment/Libraries
35 BuildArch: noarch
36
37 %description common
38 libX11 common data
39
40 %package devel
41 Summary: Development files for %{name}
42 Group: Development/Libraries
43 Requires: %{name} = %{version}-%{release}
44 Provides: libx11-devel
45
46 %description devel
47 X.Org X11 libX11 development package
48
49 %prep
50 %setup -q
51
52
53 %build
54 # sodding libtool
55 autoreconf -v --install --force
56 %reconfigure --disable-static \
57            --enable-specs \
58            --enable-man-pages=3 \
59            --with-xcb=yes \
60            CFLAGS="${CFLAGS} " \
61            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
62
63 make %{?jobs:-j%jobs}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
69
70 # We intentionally don't ship *.la files
71 find $RPM_BUILD_ROOT -type f -name '*.la' -delete
72
73 # FIXME: Don't install Xcms.txt - find out why upstream still ships this.
74 find $RPM_BUILD_ROOT -name 'Xcms.txt' -delete
75
76 # FIXME package these properly
77 rm -rf $RPM_BUILD_ROOT%{_docdir}
78
79 %remove_docs
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(-,root,root,-)
89 %{_libdir}/libX11.so.6
90 %{_libdir}/libX11.so.6.3.0
91 %{_libdir}/libX11-xcb.so.1
92 %{_libdir}/libX11-xcb.so.1.0.0
93
94 %files common
95 %defattr(-,root,root,-)
96 %doc AUTHORS COPYING README NEWS
97 %{_datadir}/X11/locale/*
98 %{_datadir}/X11/XErrorDB
99
100 %files devel
101 %defattr(-,root,root,-)
102 %{_includedir}/X11/ImUtil.h
103 %{_includedir}/X11/XKBlib.h
104 %{_includedir}/X11/Xcms.h
105 %{_includedir}/X11/Xlib.h
106 %{_includedir}/X11/XlibConf.h
107 %{_includedir}/X11/Xlibint.h
108 %{_includedir}/X11/Xlib-xcb.h
109 %{_includedir}/X11/Xlocale.h
110 %{_includedir}/X11/Xregion.h
111 %{_includedir}/X11/Xresource.h
112 %{_includedir}/X11/Xutil.h
113 %{_includedir}/X11/cursorfont.h
114 %{_libdir}/libX11.so
115 %{_libdir}/libX11-xcb.so
116 %{_libdir}/pkgconfig/x11.pc
117 %{_libdir}/pkgconfig/x11-xcb.pc
118 #%{_mandir}/man3/*.3*
119 #%{_mandir}/man5/*.5*