upload tizen2.0 source
[framework/uifw/xorg/lib/libsm.git] / packaging / libSM.spec
1 Summary: X.Org X11 SM runtime library
2 Name: libSM
3 Version: 1.2.1
4 Release: 1
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig
12 BuildRequires:  pkgconfig(xproto)
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-4
15 BuildRequires: libICE-devel
16 BuildRequires: libuuid-devel
17
18 %description
19 The X.Org X11 SM (Session Management) runtime library.
20
21 %package devel
22 Summary: X.Org X11 SM development package
23 Group: Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25 Requires: libICE-devel
26
27 %description devel
28 The X.Org X11 SM (Session Management) development package.
29
30 %prep
31 %setup -q
32
33 %build
34
35 %reconfigure --with-libuuid --disable-static \
36            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 make install DESTDIR=$RPM_BUILD_ROOT
43
44 # We intentionally don't ship *.la files
45 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
46
47 # we %%doc these ourselves, later, and only the text versions
48 rm -rf $RPM_BUILD_ROOT%{_docdir}
49
50 %remove_docs
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post -p /sbin/ldconfig
56 %postun -p /sbin/ldconfig
57
58 %files
59 %defattr(-,root,root,-)
60 %doc AUTHORS COPYING ChangeLog
61 %{_libdir}/libSM.so.6
62 %{_libdir}/libSM.so.6.*
63
64 %files devel
65 %defattr(-,root,root,-)
66 %dir %{_includedir}/X11/SM
67 %{_includedir}/X11/SM/SM.h
68 %{_includedir}/X11/SM/SMlib.h
69 %{_includedir}/X11/SM/SMproto.h
70 %{_libdir}/libSM.so
71 %{_libdir}/pkgconfig/sm.pc