Initialize Tizen 2.3
[framework/uifw/xorg/lib/libsm.git] / packaging / libSM.spec
1 Summary: X.Org X11 SM runtime library
2 Name: libSM
3 Version: 1.2.1
4 Release: 1
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig
12 BuildRequires:  pkgconfig(xproto)
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-4
15 BuildRequires: libICE-devel
16 BuildRequires: libuuid-devel
17
18 %description
19 The X.Org X11 SM (Session Management) runtime library.
20
21 %package devel
22 Summary: X.Org X11 SM development package
23 Group: Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25 Requires: libICE-devel
26
27 %description devel
28 The X.Org X11 SM (Session Management) development package.
29
30 %prep
31 %setup -q
32
33 %build
34
35 %reconfigure --with-libuuid --disable-static \
36            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 mkdir -p %{buildroot}/usr/share/license
42 cp -af COPYING %{buildroot}/usr/share/license/%{name}
43 make install DESTDIR=$RPM_BUILD_ROOT
44
45 # We intentionally don't ship *.la files
46 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
47
48 # we %%doc these ourselves, later, and only the text versions
49 rm -rf $RPM_BUILD_ROOT%{_docdir}
50
51 %remove_docs
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post -p /sbin/ldconfig
57 %postun -p /sbin/ldconfig
58
59 %files
60 %defattr(-,root,root,-)
61 /usr/share/license/%{name}
62 #%doc AUTHORS COPYING ChangeLog
63 %{_libdir}/libSM.so.6
64 %{_libdir}/libSM.so.6.*
65
66 %files devel
67 %defattr(-,root,root,-)
68 %dir %{_includedir}/X11/SM
69 %{_includedir}/X11/SM/SM.h
70 %{_includedir}/X11/SM/SMlib.h
71 %{_includedir}/X11/SM/SMproto.h
72 %{_libdir}/libSM.so
73 %{_libdir}/pkgconfig/sm.pc
74