Tizen 2.0 Release
[external/lcms.git] / packaging / lcms2.spec
1 #
2 # spec file for package lcms2
3 #
4 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18 %define _unpackaged_files_terminate_build 0
19
20 Name:           lcms2
21 Summary:        Little CMS Engine - A color managment library and tools
22 License:        MIT
23 Group:          Productivity/Graphics/Other
24 Url:            http://www.littlecms.com/
25 Version:        2.3
26 Release:        6
27
28 BuildRequires:  libjpeg-turbo-devel
29 BuildRequires:  zlib-devel
30 BuildRequires:  libtiff-devel
31
32 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
33 Source0:        %{name}-%{version}.tar.gz
34 Source1:        baselibs.conf
35 Patch:          lcms-endian.patch
36 Patch1:         lcms2-ocloexec.patch
37 Patch2:         lcms2-visibility.patch
38
39 %description
40 Littlecms is a small speed optimized color management engine.
41 Little CMS intends to be a small-footprint color management engine
42 with a special focus on accuracy and performance. It uses the International
43 Color Consortium standard (ICC), which is the modern standard when
44 regarding to color management. The ICC specification is widely used and is
45 referred to in many International and other de-facto standards.
46
47 %package -n liblcms2
48 Summary:        Libraries for the Little CMS Engine
49 Group:          System/Libraries
50
51 %description -n liblcms2
52 Little CMS Engine - A color managment library and tools.
53
54 %package -n liblcms2-devel
55 Summary:        Include Files and Libraries Mandatory for Development
56 Group:          Development/Libraries/C and C++
57 Requires:       liblcms2 = %{version} glibc-devel
58
59 %description -n liblcms2-devel
60 This package contains all necessary include files and libraries needed
61 to develop applications that require these.
62
63 #%package -n liblcms2-doc
64 #Summary:        User and developer documentation for lcms2
65 #Group:          Documentation/Other
66 #BuildArch:      noarch
67
68 #%description -n liblcms2-doc
69 #This package contains user and developer documentation for lcms2.
70
71 %package -n liblcms2-utils
72 License:        MIT License (or similar)
73 Summary:        Include Files and Libraries Mandatory for Development
74 Requires:       liblcms2 = %{version}
75 Group:          Development/Libraries/C and C++
76
77 %description -n liblcms2-utils
78 Little CMS color management library utilities
79 lcms is a standalone CMM engine, which deals with the color management.
80 LittleCMS implements a fast transformation between ICC profiles. The
81 intention of it is to be portable across several platforms. This package
82 contains additional utilities(jpegicc and tifficc) which comes with lcms.
83
84
85 %prep
86 %setup -q
87 %patch
88 %patch1
89 %patch2
90 chmod a-x doc/* COPYING AUTHORS
91
92 %build
93 export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
94 #export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
95
96 #export CFLAGS="-O2 -fPIC -I../include -fno-exceptions -fomit-frame-pointer -Wall"
97 export CXXFLAGS="$RPM_OPT_FLAGS"
98
99 %configure --prefix=/usr --disable-static
100
101 make %{?_smp_flags} CFLAGS="$CFLAGS"
102
103 #%check
104 # FIXME before submitting to factory
105 # make %{?_smp_flags} check || true
106 # make utils
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %makeinstall
111 mkdir -p %{buildroot}/usr/share/license
112 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/liblcms2-utils
113 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/liblcms2
114
115 #rm $RPM_BUILD_ROOT/%_libdir/liblcms2.la
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post -n liblcms2 -p /sbin/ldconfig
121
122 %postun -n liblcms2 -p /sbin/ldconfig
123
124 %files -n liblcms2-utils
125 %manifest liblcms2-utils.manifest
126 %defattr(-,root,root)
127 /usr/share/license/liblcms2-utils
128 %{_bindir}/*
129 %exclude %{_mandir}/man?/*.*
130
131 %files -n liblcms2
132 %manifest liblcms2.manifest
133 %defattr(-,root,root)
134 /usr/share/license/liblcms2
135 %{_libdir}/liblcms2.so.2*
136
137 %files -n liblcms2-devel
138 %defattr(-,root,root)
139 %{_includedir}/*.h
140 %{_libdir}/*.so
141 %{_libdir}/*.la
142 %{_libdir}/pkgconfig/*.pc
143
144 #%files -n liblcms2-doc
145 #%defattr(-,root,root)
146 #%doc doc/*.pdf
147
148 %changelog
149 * Sat Dec 17 2011 adrian@suse.de
150 - update to version 2.3
151   * Full support for ICC 4.3
152 * Thu Nov 24 2011 crrodriguez@opensuse.org
153 - Open all fds with O_CLOEXEC
154 - Use gcc visibility, symbol table shrinks around 50%% ...
155 * Fri Jun 10 2011 mrdocs@opensuse.org
156 -update to 2.2
157   * maintenance update
158   +Version  2.2 adds stability.
159   - fixes all known bugs
160   - adds support  for dictionary  metatag. Pascal unit now compiles
161   under FPK Pascal as well as Delphi.
162 * Mon Apr 18 2011 ro@suse.de
163 - fix devel package name in baselibs.conf
164 * Sun Dec 26 2010 adrian@suse.de
165 - update to version 2.1
166   * maintenance release (no further details in changelog)
167 - remove obsolete patches
168 * Wed Nov 10 2010 mrdocs@opensuse.org
169 - build documentation noarch and recompress tar
170 * Fri Oct  8 2010 mrdocs@opensuse.org
171 -more spec file cleanups and prepare for factory submit
172 -test building against it in my home repo
173 * Tue May 18 2010 adrian@suse.de
174 - initial lcms2 package, based on package from version 1
175 - use OBS source services to download tar ball