Add a plugin for app-defined loader
[platform/core/appfw/launchpad.git] / packaging / launchpad.spec
1 Name:       launchpad
2 Summary:    Launchpad for launching applications
3 Version:    0.11.0
4 Release:    1
5 Group:      Application Framework/Daemons
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source101:  launchpad-process-pool.service
9 Source102:  launchpad-process-pool.socket
10
11
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(bundle)
14 BuildRequires:  pkgconfig(gio-2.0)
15 BuildRequires:  pkgconfig(ecore)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(libsystemd)
18 BuildRequires:  pkgconfig(elementary)
19 BuildRequires:  pkgconfig(vconf)
20 BuildRequires:  pkgconfig(buxton2)
21 BuildRequires:  pkgconfig(security-manager)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(ttrace)
24 BuildRequires:  pkgconfig(libtzplatform-config)
25 BuildRequires:  pkgconfig(libcap)
26 BuildRequires:  pkgconfig(tanchor)
27 BuildRequires:  pkgconfig(dbus-1)
28 BuildRequires:  pkgconfig(iniparser)
29 BuildRequires:  pkgconfig(libxml-2.0)
30
31 Requires(post): /sbin/ldconfig
32 Requires(post): /usr/bin/systemctl
33 Requires(postun): /sbin/ldconfig
34 Requires(postun): /usr/bin/systemctl
35 Requires(preun): /usr/bin/systemctl
36
37 Provides: app-launchpad
38 Obsoletes: amd-mod-launchpad
39
40 %define tizen_feature_priority_change 0
41 %define tizen_feature_loader_priority 0
42 %ifarch armv7l i586
43 %define tizen_arch32 1
44 %else
45 %define tizen_arch32 0
46 %endif
47
48
49 %if "%{?_prelink_enable}" == "y"
50 %define tizen_feature_prelink 1
51 %else
52 %define tizen_feature_prelink 0
53 %endif
54
55 %description
56 Launchpad for launching applications
57
58 %package devel
59 Summary:    Launchpad for launching applications (devel)
60 Group:      Development/Libraries
61 Requires:   liblaunchpad = %{version}-%{release}
62
63 %description devel
64 Launchpad for launching applications (devel)
65
66 %package -n launchpad-loader
67 Summary:    Launchpad-Loader for launching applications
68 Group:      Application Framework/Application Launcher
69
70 %description -n launchpad-loader
71 Launchpad-Loader for launching applications
72
73 %package -n liblaunchpad
74 Summary:    Launchpad library
75 Group:      Development/Libraries
76
77 %description -n liblaunchpad
78 Launchpad library
79
80 %package -n liblaunchpad-devel
81 Summary:    Launchpad library (devel)
82 Group:      Development/Libraries
83 Requires:   liblaunchpad = %{version}-%{release}
84
85 %description -n liblaunchpad-devel
86 Launchpad library (devel)
87
88 %prep
89 %setup -q
90
91 %build
92 %if 0%{?sec_build_binary_debug_enable}
93 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
94 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
95 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
96 %endif
97 %if 0%{?tizen_feature_priority_change}
98 _TIZEN_FEATURE_PRIORITY_CHANGE=ON
99 %endif
100 %if 0%{?tizen_feature_loader_priority}
101 _TIZEN_FEATURE_LOADER_PRIORITY=ON
102 %endif
103 %if 0%{?tizen_arch32}
104 _TIZEN_FEATURE_SET_PERSONALITY_32=ON
105 %endif
106 %if 0%{?tizen_feature_prelink}
107 _TIZEN_FEATURE_PRELINK=ON
108 %endif
109
110 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
111 %cmake -DVERSION=%{version} \
112         -DMAJORVER=${MAJORVER} \
113         -D_TIZEN_FEATURE_PRIORITY_CHANGE:BOOL=${_TIZEN_FEATURE_PRIORITY_CHANGE} \
114         -D_TIZEN_FEATURE_LOADER_PRIORITY:BOOL=${_TIZEN_FEATURE_LOADER_PRIORITY} \
115         -D_TIZEN_FEATURE_SET_PERSONALITY_32:BOOL=${_TIZEN_FEATURE_SET_PERSONALITY_32} \
116         -D_TIZEN_FEATURE_PRELINK:BOOL=${_TIZEN_FEATURE_PRELINK} \
117         .
118 %__make %{?_smp_mflags}
119
120 %install
121 rm -rf %{buildroot}
122
123
124 %make_install
125 mkdir -p %{buildroot}%{_unitdir_user}/basic.target.wants
126 mkdir -p %{buildroot}%{_unitdir_user}/sockets.target.wants
127 install -m 0644 %SOURCE101 %{buildroot}%{_unitdir_user}/launchpad-process-pool.service
128 install -m 0644 %SOURCE102 %{buildroot}%{_unitdir_user}/launchpad-process-pool.socket
129 ln -sf ../launchpad-process-pool.socket %{buildroot}%{_unitdir_user}/sockets.target.wants/launchpad-process-pool.socket
130 ln -sf ../launchpad-process-pool.service %{buildroot}%{_unitdir_user}/basic.target.wants/launchpad-process-pool.service
131
132 %post
133
134 %files
135 %manifest launchpad.manifest
136 %license LICENSE
137 %{_prefix}/share/aul/default.debugger
138 %{_unitdir_user}/launchpad-process-pool.service
139 %{_unitdir_user}/launchpad-process-pool.socket
140 %{_unitdir_user}/sockets.target.wants/launchpad-process-pool.socket
141 %{_unitdir_user}/basic.target.wants/launchpad-process-pool.service
142 %{_bindir}/launchpad-process-pool
143 %{_prefix}/share/aul/launchpad.conf
144 %{_sysconfdir}/package-manager/parserlib/liblaunchpad-parser.so
145 %{_datadir}/parser-plugins/*
146
147 %files devel
148 %{_includedir}/launchpad/*.h
149 %{_libdir}/*.so
150 %{_libdir}/pkgconfig/launchpad.pc
151
152 %files -n launchpad-loader
153 %manifest launchpad-loader.manifest
154 %license LICENSE
155 %{_prefix}/share/aul/default.loader
156 %{_bindir}/launchpad-loader
157
158 %files -n liblaunchpad
159 %manifest liblaunchpad.manifest
160 %license LICENSE
161 %attr(0644,root,root) %{_libdir}/liblaunchpad.so.*
162 %attr(0644,root,root) %{_libdir}/liblaunchpad-hydra.so.*
163
164 %files -n liblaunchpad-devel
165 %{_includedir}/launchpad/*.h
166 %{_libdir}/*.so
167 %{_libdir}/pkgconfig/liblaunchpad.pc
168 %{_libdir}/pkgconfig/liblaunchpad-hydra.pc
169