Release version 0.5.7
[platform/core/appfw/launchpad.git] / packaging / launchpad.spec
1 Name:       launchpad
2 Summary:    Launchpad for launching applications
3 Version:    0.5.7
4 Release:    1
5 Group:      Application Framework/Daemons
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source101:  launchpad-process-pool.service
9 Source102:  launchpad-process-pool.socket
10
11
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(bundle)
14 BuildRequires:  pkgconfig(gio-2.0)
15 BuildRequires:  pkgconfig(ecore)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(libsystemd)
18 BuildRequires:  pkgconfig(elementary)
19 BuildRequires:  pkgconfig(vconf)
20 BuildRequires:  pkgconfig(buxton2)
21 BuildRequires:  pkgconfig(security-manager)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(ttrace)
24 BuildRequires:  pkgconfig(libtzplatform-config)
25 BuildRequires:  pkgconfig(libcap)
26 BuildRequires:  pkgconfig(tanchor)
27 BuildRequires:  pkgconfig(dbus-1)
28
29 Requires(post): /sbin/ldconfig
30 Requires(post): /usr/bin/systemctl
31 Requires(postun): /sbin/ldconfig
32 Requires(postun): /usr/bin/systemctl
33 Requires(preun): /usr/bin/systemctl
34
35 Provides: app-launchpad
36 Obsoletes: amd-mod-launchpad
37
38 %define tizen_feature_priority_change 0
39 %define tizen_feature_loader_priority 0
40 %ifarch armv7l i586
41 %define tizen_arch32 1
42 %else
43 %define tizen_arch32 0
44 %endif
45
46 %description
47 Launchpad for launching applications
48
49 %package devel
50 Summary:    Launchpad for launching applications (devel)
51 Group:      Development/Libraries
52 Requires:   %{name} = %{version}-%{release}
53
54 %description devel
55 Launchpad for launching applications (devel)
56
57 %package -n launchpad-loader
58 Summary:    Launchpad-Loader for launching applications
59 Group:      Application Framework/Application Launcher
60
61 %description -n launchpad-loader
62 Launchpad-Loader for launching applications
63
64 %prep
65 %setup -q
66
67 %build
68 %if 0%{?sec_build_binary_debug_enable}
69 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
70 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
71 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
72 %endif
73 %if 0%{?tizen_feature_priority_change}
74 _TIZEN_FEATURE_PRIORITY_CHANGE=ON
75 %endif
76 %if 0%{?tizen_feature_loader_priority}
77 _TIZEN_FEATURE_LOADER_PRIORITY=ON
78 %endif
79 %if 0%{?tizen_arch32}
80 _TIZEN_FEATURE_SET_PERSONALITY_32=ON
81 %endif
82
83 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
84 %cmake -DVERSION=%{version} \
85         -DMAJORVER=${MAJORVER} \
86         -D_TIZEN_FEATURE_PRIORITY_CHANGE:BOOL=${_TIZEN_FEATURE_PRIORITY_CHANGE} \
87         -D_TIZEN_FEATURE_LOADER_PRIORITY:BOOL=${_TIZEN_FEATURE_LOADER_PRIORITY} \
88         -D_TIZEN_FEATURE_SET_PERSONALITY_32:BOOL=${_TIZEN_FEATURE_SET_PERSONALITY_32} \
89         .
90 %__make %{?_smp_mflags}
91
92 %install
93 rm -rf %{buildroot}
94
95 %make_install
96 mkdir -p %{buildroot}%{_unitdir_user}/basic.target.wants
97 mkdir -p %{buildroot}%{_unitdir_user}/sockets.target.wants
98 install -m 0644 %SOURCE101 %{buildroot}%{_unitdir_user}/launchpad-process-pool.service
99 install -m 0644 %SOURCE102 %{buildroot}%{_unitdir_user}/launchpad-process-pool.socket
100 ln -sf ../launchpad-process-pool.socket %{buildroot}%{_unitdir_user}/sockets.target.wants/launchpad-process-pool.socket
101 ln -sf ../launchpad-process-pool.service %{buildroot}%{_unitdir_user}/basic.target.wants/launchpad-process-pool.service
102
103 %post
104
105 %files
106 %manifest launchpad.manifest
107 %license LICENSE
108 %{_prefix}/share/aul/default.debugger
109 %{_unitdir_user}/launchpad-process-pool.service
110 %{_unitdir_user}/launchpad-process-pool.socket
111 %{_unitdir_user}/sockets.target.wants/launchpad-process-pool.socket
112 %{_unitdir_user}/basic.target.wants/launchpad-process-pool.service
113 %{_bindir}/launchpad-process-pool
114 %attr(0644,root,root) %{_libdir}/liblaunchpad.so.*
115
116 %files devel
117 %{_includedir}/launchpad/*.h
118 %{_libdir}/*.so
119 %{_libdir}/pkgconfig/*.pc
120
121 %files -n launchpad-loader
122 %manifest %{name}.manifest
123 %license LICENSE
124 %{_prefix}/share/aul/default.loader
125 %{_bindir}/launchpad-loader