2 Summary: JavaScript interpreter
3 License: MPL-1.1 or GPL-2.0+ or LGPL-2.1+
4 Group: Development/Languages/Other
7 Url: http://www.mozilla.org/js/
8 Source0: http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.bz2
9 Source98: baselibs.conf
10 BuildRoot: %{_tmppath}/%{name}-%{version}-build
11 BuildRequires: autoconf213
12 BuildRequires: gcc-c++
13 BuildRequires: nspr-devel
14 BuildRequires: pkg-config
20 JavaScript is the Netscape-developed object scripting language used in millions
21 of web pages and server applications worldwide. Netscape's JavaScript is a
22 superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
23 with only mild differences from the published standard.
25 %package -n libmozjs185
26 Summary: JavaScript library
27 Group: System/Libraries
29 %description -n libmozjs185
30 JavaScript is the Netscape-developed object scripting language used in millions
31 of web pages and server applications worldwide. Netscape's JavaScript is a
32 superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
33 with only mild differences from the published standard.
37 Summary: Header files, libraries and development documentation for %{name}
38 Group: Development/Libraries/Other
39 Requires: libmozjs185 = %{version}-%{release}
41 Provides: libjs-devel = %{version}-%{release}
42 Provides: mozjs185-devel
45 This package contains the header files, static libraries and development
46 documentation for %{name}. If you like to develop programs using %{name},
47 you will need to install %{name}-devel.
50 %setup -q -n %{name}-%{version}
53 export MOZILLA_VERSION=%{version}
56 %configure --with-system-nspr --enable-threadsafe
59 %{__make} %{?_smp_mflags} -C src \
61 XCFLAGS="%{optflags} -fPIC " \
67 %{__rm} -rf %{buildroot}%{_libdir}/libmozjs185-1.0.a
68 # SO links are created wrong, fixing them
69 %{__rm} -rf %{buildroot}%{_libdir}/libmozjs185.so.1.0
70 %{__rm} -rf %{buildroot}%{_libdir}/libmozjs185.so
71 %{__ln_s} libmozjs185.so.1.0.0 %{buildroot}%{_libdir}/libmozjs185.so.1.0
72 %{__ln_s} libmozjs185.so.1.0.0 %{buildroot}%{_libdir}/libmozjs185.so
74 %{__install} -m 0755 shell/js %{buildroot}%{_bindir}/
75 # headers are installed with executable permissions
76 chmod 644 %{buildroot}%{_includedir}/js/*
79 %{__rm} -rf %{buildroot}
81 %post -n libmozjs185 -p /sbin/ldconfig
83 %postun -n libmozjs185 -p /sbin/ldconfig
86 %defattr(-,root,root,-)
87 %doc js/src/README.html
91 %defattr(-,root,root,-)
95 %defattr(-,root,root,-)
98 %{_libdir}/pkgconfig/*.pc