resetting manifest requested domain to floor
[platform/upstream/jasper.git] / packaging / jasper.spec
1 #
2 # Please submit bugfixes or comments via http://bugs.tizen.org/
3 #
4
5 Name:           jasper
6 Version:        1.900.1
7 Release:        144
8 License:        SUSE-Public-Domain
9 Summary:        An Implementation of the JPEG-2000 Standard, Part 1
10 Url:            http://www.ece.uvic.ca/~mdadams/jasper/
11 Group:          Productivity/Graphics/Convertors
12 Source:         %{name}-%{version}.tar.bz2
13 Source98:       baselibs.conf
14 Source1001:     jasper.manifest
15 BuildRequires:  gcc-c++
16 BuildRequires:  libdrm-devel
17 BuildRequires:  libjpeg8-devel
18 BuildRequires:  libtool
19 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
20
21 %description
22 This package contains an implementation of the image compression
23 standard, JPEG-2000, Part 1. It consists of tools for conversion to and
24 from the JP2 and JPC formats.
25
26 %package -n libjasper
27 License:        SUSE-Public-Domain
28 Summary:        JPEG-2000 library
29 Group:          Productivity/Graphics/Convertors
30
31 %description -n libjasper
32 This package contains libjasper, a library implementing the JPEG-2000
33 image compression standard Part 1.
34
35 %package -n libjasper-devel
36 License:        SUSE-Public-Domain
37 Summary:        JPEG-2000 library - files mandatory for development
38 Group:          Development/Libraries/C and C++
39 Requires:       libjasper = %{version}
40 Requires:       libjpeg8-devel
41
42 %description -n libjasper-devel
43 This package contains libjasper, a library implementing the JPEG-2000
44 image compression standard Part 1.
45
46 %prep
47 %setup -q
48 cp %{SOURCE1001} .
49
50 %build
51 autoreconf -i -f
52 export CFLAGS="%{optflags} -Wall"
53 %configure --prefix=/usr --enable-shared --disable-static --libdir=%{_libdir}
54 make %{?_smp_mflags}
55
56 %install
57 %make_install
58 rm %{buildroot}/usr/bin/tmrdemo
59 # compatibility link, there was no interface change
60 ln -s libjasper.so.1.0.0 %{buildroot}%{_libdir}/libjasper-1.701.so.1
61
62 %post -n libjasper -p /sbin/ldconfig
63
64 %postun -n libjasper -p /sbin/ldconfig
65
66 %docs_package
67
68 %files
69 %manifest %{name}.manifest
70 %defattr(-,root,root)
71 %doc COPYRIGHT
72 /usr/bin/imgcmp
73 /usr/bin/imginfo
74 /usr/bin/jasper
75
76 %files -n libjasper
77 %manifest %{name}.manifest
78 %defattr(-,root,root)
79 %{_libdir}/libjasper*.so.*
80
81 %files -n libjasper-devel
82 %manifest %{name}.manifest
83 %defattr(-,root,root)
84 /usr/include/jasper
85 %{_libdir}/libjasper.so